aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-03-19 23:48:38 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-03-19 23:48:38 +0000
commitd573506eb100e6a61985872f7b87d6ce21b57fe5 (patch)
treed7aa51a40e1b93107ede1fc166c779e93401dea0 /package/kernel
parent8634e64038b8e37b7f788f7f0e1e496a8a90ee05 (diff)
downloadupstream-d573506eb100e6a61985872f7b87d6ce21b57fe5.tar.gz
upstream-d573506eb100e6a61985872f7b87d6ce21b57fe5.tar.bz2
upstream-d573506eb100e6a61985872f7b87d6ce21b57fe5.zip
[package] kernel: add kmod-acpi-button
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31037 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk17
1 files changed, 16 insertions, 1 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index b57d055d36..69c7a78fcb 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -1,5 +1,5 @@
#
-# Copyright (C) 2006-2011 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
@@ -890,3 +890,18 @@ endef
$(eval $(call KernelPackage,serial-8250))
+
+define KernelPackage/acpi-button
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=ACPI Button Support
+ DEPENDS:=@(TARGET_x86_generic||TARGET_x86_kvm_guest||TARGET_x86_xen_domu) +kmod-input-evdev
+ KCONFIG:=CONFIG_ACPI_BUTTON
+ FILES:=$(LINUX_DIR)/drivers/acpi/button.ko
+ AUTOLOAD:=$(call AutoLoad,06,button)
+endef
+
+define KernelPackage/acpi-button/description
+ Kernel module for ACPI Button support
+endef
+
+$(eval $(call KernelPackage,acpi-button))