aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorDaniel Albers <daniel.albers@public-files.de>2017-12-28 18:36:24 +0100
committerJohn Crispin <john@phrozen.org>2018-01-02 14:29:04 +0100
commitd30c0f4d50b3153dafdbbf892fe255b4e3d175a0 (patch)
tree38a2019f66607958d7742fd8f4e73bc506c19c00 /package/kernel
parent16ed8ac8e9b76f8f9df322c8fe8be84258540940 (diff)
downloadupstream-d30c0f4d50b3153dafdbbf892fe255b4e3d175a0.tar.gz
upstream-d30c0f4d50b3153dafdbbf892fe255b4e3d175a0.tar.bz2
upstream-d30c0f4d50b3153dafdbbf892fe255b4e3d175a0.zip
kernel: make uas work during early boot
Add the uas(p) module to the modules loaded early on the boot process. The uas(p) is an modern alternative, which is used by the modern USB3 storage cases, compared to the bot protocol. To be able to use uas(p) storage cases for extroot, the kernel module has to be loaded before the search for extroot has been called. This patch changes the load order to support uas(p) storage cases for extroot. Signed-off-by: Daniel Albers <daniel.albers@public-files.de>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/usb.mk2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index d1fb5f4cd2..08e3bf699e 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -894,7 +894,7 @@ define KernelPackage/usb-storage-uas
DEPENDS:=+kmod-usb-storage
KCONFIG:=CONFIG_USB_UAS
FILES:=$(LINUX_DIR)/drivers/usb/storage/uas.ko
- AUTOLOAD:=$(call AutoProbe,uas)
+ AUTOLOAD:=$(call AutoProbe,uas,1)
endef
define KernelPackage/usb-storage-uas/description