aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-03-16 10:13:14 +0100
committerFelix Fietkau <nbd@nbd.name>2017-06-07 18:31:10 +0200
commitc6c1f6a5480b12c938ae4154a55a08a559e8e46b (patch)
treeffd0672e38a268ccf1ee7e8d0ee451573040bf87 /package/kernel
parent0aed054becb2143952bfb77cb64e23c83ce79dfd (diff)
downloadupstream-c6c1f6a5480b12c938ae4154a55a08a559e8e46b.tar.gz
upstream-c6c1f6a5480b12c938ae4154a55a08a559e8e46b.tar.bz2
upstream-c6c1f6a5480b12c938ae4154a55a08a559e8e46b.zip
mac80211: use KERNEL_MAKEOPTS
Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/mac80211/Makefile7
-rw-r--r--package/kernel/mac80211/patches/012-kernel_build_check.patch11
2 files changed, 12 insertions, 6 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 71aae89360..1ac390d337 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -1659,8 +1659,7 @@ config-y += RTL8XXXU_UNTESTED
config-$(CONFIG_LEDS_TRIGGERS) += MAC80211_LEDS B43_LEDS B43LEGACY_LEDS
MAKE_OPTS:= -C "$(PKG_BUILD_DIR)" \
- CROSS_COMPILE="$(KERNEL_CROSS)" \
- ARCH="$(LINUX_KARCH)" \
+ $(KERNEL_MAKE_FLAGS) \
EXTRA_CFLAGS="-I$(PKG_BUILD_DIR)/include $(IREMAP_CFLAGS)" \
KLIB_BUILD="$(LINUX_DIR)" \
MODPROBE=true \
@@ -1668,10 +1667,6 @@ MAKE_OPTS:= -C "$(PKG_BUILD_DIR)" \
KERNEL_SUBLEVEL=$(lastword $(subst ., ,$(KERNEL_PATCHVER))) \
KBUILD_LDFLAGS_MODULE_PREREQ=
-ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)
- MAKE_OPTS += V=1
-endif
-
define ConfigVars
$(subst $(space),,$(foreach opt,$(config-$(1)),CPTCFG_$(opt)=$(1)
))
diff --git a/package/kernel/mac80211/patches/012-kernel_build_check.patch b/package/kernel/mac80211/patches/012-kernel_build_check.patch
new file mode 100644
index 0000000000..d225ba1820
--- /dev/null
+++ b/package/kernel/mac80211/patches/012-kernel_build_check.patch
@@ -0,0 +1,11 @@
+--- a/Makefile
++++ b/Makefile
+@@ -2,7 +2,7 @@
+ # Makefile for the output source package
+ #
+
+-ifeq ($(KERNELRELEASE),)
++ifeq ($(KERNELVERSION),)
+
+ MAKEFLAGS += --no-print-directory
+ SHELL := /usr/bin/env bash