aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2019-07-29 16:54:02 +0100
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2020-04-01 21:59:45 +0100
commitb74386acc6793ee7effe92153e93e3f9fad7fc9c (patch)
tree6410010dd9c885c90cd19f2ac2567cc99296d423 /package/kernel
parent475738c9af41c503eda01c756f5c8dcb95d2c50b (diff)
downloadupstream-b74386acc6793ee7effe92153e93e3f9fad7fc9c.tar.gz
upstream-b74386acc6793ee7effe92153e93e3f9fad7fc9c.tar.bz2
upstream-b74386acc6793ee7effe92153e93e3f9fad7fc9c.zip
kmod-sched-cake: switch to in-tree cake for 4.19+
Use in tree version of cake for kernels 4.19+ and backport features from later kernel versions to 4.19. Unfortunately PROVIDES dependency handling produces bogus circular dependency warnings so whilst this package and kmod-sched-cake-oot should be able to PROVIDE kmod-sched-cake this doesn't work. Instead, remove the PROVIDES option and modify package sqm-scripts to depend on the correct module independently. Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/kmod-sched-cake-oot/Makefile3
-rw-r--r--package/kernel/linux/modules/netsupport.mk17
2 files changed, 17 insertions, 3 deletions
diff --git a/package/kernel/kmod-sched-cake-oot/Makefile b/package/kernel/kmod-sched-cake-oot/Makefile
index e53e42eb9c..963681c1fb 100644
--- a/package/kernel/kmod-sched-cake-oot/Makefile
+++ b/package/kernel/kmod-sched-cake-oot/Makefile
@@ -26,8 +26,7 @@ define KernelPackage/sched-cake-oot
URL:=https://github.com/dtaht/sch_cake
FILES:=$(PKG_BUILD_DIR)/sch_cake.ko
AUTOLOAD:=$(call AutoLoad,75,sch_cake)
- DEPENDS:=+kmod-sched-core +kmod-ipt-conntrack
- PROVIDES:=kmod-sched-cake
+ DEPENDS:=@LINUX_4_14 +kmod-sched-core +kmod-ipt-conntrack
endef
include $(INCLUDE_DIR)/kernel-defaults.mk
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index b3b32877a3..ca25138571 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -746,7 +746,7 @@ $(eval $(call KernelPackage,mppe))
SCHED_MODULES = $(patsubst $(LINUX_DIR)/net/sched/%.ko,%,$(wildcard $(LINUX_DIR)/net/sched/*.ko))
SCHED_MODULES_CORE = sch_ingress sch_fq_codel sch_hfsc sch_htb sch_tbf cls_basic cls_fw cls_route cls_flow cls_tcindex cls_u32 em_u32 act_mirred act_skbedit cls_matchall
-SCHED_MODULES_FILTER = $(SCHED_MODULES_CORE) act_connmark act_ctinfo sch_netem sch_mqprio em_ipset cls_bpf cls_flower act_bpf act_vlan
+SCHED_MODULES_FILTER = $(SCHED_MODULES_CORE) act_connmark act_ctinfo sch_cake sch_netem sch_mqprio em_ipset cls_bpf cls_flower act_bpf act_vlan
SCHED_MODULES_EXTRA = $(filter-out $(SCHED_MODULES_FILTER),$(SCHED_MODULES))
SCHED_FILES = $(patsubst %,$(LINUX_DIR)/net/sched/%.ko,$(filter $(SCHED_MODULES_CORE),$(SCHED_MODULES)))
SCHED_FILES_EXTRA = $(patsubst %,$(LINUX_DIR)/net/sched/%.ko,$(SCHED_MODULES_EXTRA))
@@ -785,6 +785,21 @@ endef
$(eval $(call KernelPackage,sched-core))
+define KernelPackage/sched-cake
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=Cake fq_codel/blue derived shaper
+ DEPENDS:=@!LINUX_4_14 +kmod-sched-core
+ KCONFIG:=CONFIG_NET_SCH_CAKE
+ FILES:=$(LINUX_DIR)/net/sched/sch_cake.ko
+ AUTOLOAD:=$(call AutoProbe,sch_cake)
+endef
+
+define KernelPackage/sched-cake/description
+ Common Applications Kept Enhanced fq_codel/blue derived shaper
+endef
+
+$(eval $(call KernelPackage,sched-cake))
+
define KernelPackage/sched-flower
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=Flower traffic classifier