aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2011-10-28 19:16:21 +0000
committerNicolas Thill <nico@openwrt.org>2011-10-28 19:16:21 +0000
commitaa48b2305372f931ed44a7349f5ff6195e82952b (patch)
tree126bf15d733759453c515ef1ea9096b02222b613 /package/kernel
parent6aa8f524f09448307a4287d9b113d27a119cb977 (diff)
downloadupstream-aa48b2305372f931ed44a7349f5ff6195e82952b.tar.gz
upstream-aa48b2305372f931ed44a7349f5ff6195e82952b.tar.bz2
upstream-aa48b2305372f931ed44a7349f5ff6195e82952b.zip
package/kernel: fix kmod-fs-cifs dependencies (closes: #9381, #10055)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@28661 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/fs.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/kernel/modules/fs.mk b/package/kernel/modules/fs.mk
index 6c253c773d..84d2311e7e 100644
--- a/package/kernel/modules/fs.mk
+++ b/package/kernel/modules/fs.mk
@@ -48,6 +48,14 @@ define KernelPackage/fs-cifs
FILES:=$(LINUX_DIR)/fs/cifs/cifs.ko
AUTOLOAD:=$(call AutoLoad,30,cifs)
$(call AddDepends/nls)
+ DEPENDS+= \
+ !(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36):kmod-crypto-core \
+ !(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36):kmod-crypto-arc4 \
+ !(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36):kmod-crypto-hmac \
+ !(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36):kmod-crypto-md5 \
+ !(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37):kmod-crypto-md4 \
+ !(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-crypto-des \
+ !(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-crypto-ecb
endef
define KernelPackage/fs-cifs/description