aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorYousong Zhou <yszhou4tech@gmail.com>2017-05-25 14:41:34 +0800
committerYousong Zhou <yszhou4tech@gmail.com>2017-05-25 22:52:07 +0800
commita76cbc0d7ec2a816682063bdc18d114ec0711113 (patch)
treeaf2bf164355d125d91d3353ba6e37cf4631eb098 /package/kernel
parente250acab26b7c5ff3ed37693bf40381962fca42c (diff)
downloadupstream-a76cbc0d7ec2a816682063bdc18d114ec0711113.tar.gz
upstream-a76cbc0d7ec2a816682063bdc18d114ec0711113.tar.bz2
upstream-a76cbc0d7ec2a816682063bdc18d114ec0711113.zip
kernel: fix autoloading arch-specific modules
Fixes FS#745 Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/crypto.mk14
-rw-r--r--package/kernel/linux/modules/sound.mk2
-rw-r--r--package/kernel/linux/modules/video.mk2
3 files changed, 9 insertions, 9 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index a89d0b7b7c..efcdeafa99 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -448,7 +448,7 @@ endef
define KernelPackage/crypto-md5/octeon
FILES+=$(LINUX_DIR)/arch/mips/cavium-octeon/crypto/octeon-md5.ko
- AUTOLOAD:=$(call AutoLoad,09,octeon-md5)
+ AUTOLOAD+=$(call AutoLoad,09,octeon-md5)
endef
$(eval $(call KernelPackage,crypto-md5))
@@ -480,12 +480,12 @@ endef
define KernelPackage/crypto-sha1/octeon
FILES+=$(LINUX_DIR)/arch/mips/cavium-octeon/crypto/octeon-sha1.ko
- AUTOLOAD:=$(call AutoLoad,09,octeon-sha1)
+ AUTOLOAD+=$(call AutoLoad,09,octeon-sha1)
endef
define KernelPackage/crypto-sha1/x86/64
FILES+=$(LINUX_DIR)/arch/x86/crypto/sha1-ssse3.ko
- AUTOLOAD:=$(call AutoLoad,09,sha1-ssse3)
+ AUTOLOAD+=$(call AutoLoad,09,sha1-ssse3)
endef
$(eval $(call KernelPackage,crypto-sha1))
@@ -505,12 +505,12 @@ endef
define KernelPackage/crypto-sha256/octeon
FILES+=$(LINUX_DIR)/arch/mips/cavium-octeon/crypto/octeon-sha256.ko
- AUTOLOAD:=$(call AutoLoad,09,octeon-sha256)
+ AUTOLOAD+=$(call AutoLoad,09,octeon-sha256)
endef
define KernelPackage/crypto-sha256/x86/64
FILES+=$(LINUX_DIR)/arch/x86/crypto/sha256-ssse3.ko
- AUTOLOAD:=$(call AutoLoad,09,sha256-ssse3)
+ AUTOLOAD+=$(call AutoLoad,09,sha256-ssse3)
endef
$(eval $(call KernelPackage,crypto-sha256))
@@ -530,12 +530,12 @@ endef
define KernelPackage/crypto-sha512/octeon
FILES+=$(LINUX_DIR)/arch/mips/cavium-octeon/crypto/octeon-sha512.ko
- AUTOLOAD:=$(call AutoLoad,09,octeon-sha512)
+ AUTOLOAD+=$(call AutoLoad,09,octeon-sha512)
endef
define KernelPackage/crypto-sha512/x86/64
FILES+=$(LINUX_DIR)/arch/x86/crypto/sha512-ssse3.ko
- AUTOLOAD:=$(call AutoLoad,09,sha512-ssse3)
+ AUTOLOAD+=$(call AutoLoad,09,sha512-ssse3)
endef
$(eval $(call KernelPackage,crypto-sha512))
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index de5d8fc2c6..75aa3d3fc4 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -67,7 +67,7 @@ define KernelPackage/sound-core/uml
FILES:= \
$(LINUX_DIR)/sound/soundcore.ko \
$(LINUX_DIR)/arch/um/drivers/hostaudio.ko
- AUTOLOAD:=$(call AutoLoad,30,soundcore hostaudio)
+ AUTOLOAD+=$(call AutoLoad,30,soundcore hostaudio)
endef
define KernelPackage/sound-core/description
diff --git a/package/kernel/linux/modules/video.mk b/package/kernel/linux/modules/video.mk
index ecea009bd6..ef6bd4bc0b 100644
--- a/package/kernel/linux/modules/video.mk
+++ b/package/kernel/linux/modules/video.mk
@@ -72,7 +72,7 @@ endef
define KernelPackage/fb/x86
FILES+=$(LINUX_DIR)/arch/x86/video/fbdev.ko
- AUTOLOAD:=$(call AutoLoad,06,fbdev fb)
+ AUTOLOAD+=$(call AutoLoad,06,fbdev fb)
endef
$(eval $(call KernelPackage,fb))