aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2021-03-17 03:12:33 -0700
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2021-03-19 14:02:47 +0000
commita374b8f190518a74dcc99d6bf3cf53adb7511963 (patch)
tree67cff907a700ca3415909a62d86ea8cbc3b7a5d4 /package/kernel
parentad11fc8c236fca5283ed500d87504543f2768312 (diff)
downloadupstream-a374b8f190518a74dcc99d6bf3cf53adb7511963.tar.gz
upstream-a374b8f190518a74dcc99d6bf3cf53adb7511963.tar.bz2
upstream-a374b8f190518a74dcc99d6bf3cf53adb7511963.zip
kernel: 5.10: update sound modules
Update file paths for kmod-sound-hda-intel and reflect new dependency of kmod-sound-hda-core on kmod-ledtrig-audio. Reported-by: Javier Marcet <javier@marcet.info> Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/sound.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 66194a5a73..2c11d078e1 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -304,6 +304,10 @@ $(eval $(call KernelPackage,sound-dummy))
define KernelPackage/sound-hda-core
SUBMENU:=$(SOUND_MENU)
TITLE:=HD Audio Sound Core Support
+ DEPENDS:= \
+ +LINUX_5_10&&PACKAGE_kmod-sound-hda-codec-realtek:kmod-ledtrig-audio \
+ +LINUX_5_10&&PACKAGE_kmod-sound-hda-codec-conexant:kmod-ledtrig-audio \
+ +LINUX_5_10&&PACKAGE_kmod-sound-hda-codec-idt:kmod-ledtrig-audio
KCONFIG:= \
CONFIG_SND_HDA_CORE \
CONFIG_SND_HDA_HWDEP=y \
@@ -522,7 +526,8 @@ define KernelPackage/sound-hda-intel
CONFIG_SND_HDA_INTEL
FILES:= \
$(LINUX_DIR)/sound/pci/hda/snd-hda-intel.ko \
- $(LINUX_DIR)/sound/hda/snd-intel-nhlt.ko
+ $(LINUX_DIR)/sound/hda/snd-intel-nhlt.ko@lt5.5 \
+ $(LINUX_DIR)/sound/hda/snd-intel-dspcfg.ko@ge5.5
AUTOLOAD:=$(call AutoProbe,snd-hda-intel)
$(call AddDepends/sound,kmod-sound-hda-core)
endef