aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-03-02 11:17:27 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-03-02 11:17:27 +0000
commit92d3043fc8df9b0467a9201393217298c170d08e (patch)
tree5e4aa801196a2f7cf2a664b0ffab5666c79ca8ab /package/kernel
parent449b44a5744bdef79dc6eba62b5628a99be5517c (diff)
downloadupstream-92d3043fc8df9b0467a9201393217298c170d08e.tar.gz
upstream-92d3043fc8df9b0467a9201393217298c170d08e.tar.bz2
upstream-92d3043fc8df9b0467a9201393217298c170d08e.zip
package/kernel: package nandsim module
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30774 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk16
1 files changed, 16 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 5a4cce8ce3..612603ba47 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -838,3 +838,19 @@ define KernelPackage/nand/description
endef
$(eval $(call KernelPackage,nand))
+
+
+define KernelPackage/nandsim
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=NAND simulator
+ DEPENDS:=+kmod-nand
+ KCONFIG:=CONFIG_MTD_NAND_NANDSIM
+ FILES:=$(LINUX_DIR)/drivers/mtd/nand/nandsim.ko
+endef
+
+define KernelPackage/nandsim/description
+ Kernel module for NAND flash simulation.
+endef
+
+$(eval $(call KernelPackage,nandsim))
+