aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2012-05-06 20:43:17 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2012-05-06 20:43:17 +0000
commit8ff6417c419a50cd0f3b3ff450df6e7f5a426478 (patch)
tree6b9d1420203da6402f8416fcb6450b33a2d660fe /package/kernel
parenta42570bc3e5c952d643c1d3ad90ad8cba270f568 (diff)
downloadupstream-8ff6417c419a50cd0f3b3ff450df6e7f5a426478.tar.gz
upstream-8ff6417c419a50cd0f3b3ff450df6e7f5a426478.tar.bz2
upstream-8ff6417c419a50cd0f3b3ff450df6e7f5a426478.zip
kernel: remove kernel modules and references to kernels <= 2.6.36
OpenWrt does not support kernel version <= 2.6.36 any more, remove all modules only build for those kernels and all conditions specific for those kernel versions. SVN-Revision: 31634
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/001-depends.mk4
-rw-r--r--package/kernel/modules/block.mk6
-rw-r--r--package/kernel/modules/crypto.mk2
-rw-r--r--package/kernel/modules/firewire.mk85
-rw-r--r--package/kernel/modules/fs.mk50
-rw-r--r--package/kernel/modules/lib.mk4
-rw-r--r--package/kernel/modules/netsupport.mk5
-rw-r--r--package/kernel/modules/other.mk21
-rw-r--r--package/kernel/modules/virtual.mk2
9 files changed, 24 insertions, 155 deletions
diff --git a/package/kernel/modules/001-depends.mk b/package/kernel/modules/001-depends.mk
index a52794b972..aad2939230 100644
--- a/package/kernel/modules/001-depends.mk
+++ b/package/kernel/modules/001-depends.mk
@@ -34,6 +34,6 @@ endef
define AddDepends/rtc
DEPENDS+= \
- +(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-rtc-core-2.6 \
- +!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-rtc-core-3.x
+ +(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-rtc-core-2.6 \
+ +!(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-rtc-core-3.x
endef
diff --git a/package/kernel/modules/block.mk b/package/kernel/modules/block.mk
index d529d0ebaa..5096ade3f5 100644
--- a/package/kernel/modules/block.mk
+++ b/package/kernel/modules/block.mk
@@ -611,11 +611,7 @@ define KernelPackage/mvsas
KCONFIG:= \
CONFIG_SCSI_MVSAS \
CONFIG_SCSI_MVSAS_TASKLET=n
- ifneq ($(CONFIG_LINUX_2_6_30),)
- FILES:=$(LINUX_DIR)/drivers/scsi/mvsas.ko
- else
- FILES:=$(LINUX_DIR)/drivers/scsi/mvsas/mvsas.ko
- endif
+ FILES:=$(LINUX_DIR)/drivers/scsi/mvsas/mvsas.ko
AUTOLOAD:=$(call AutoLoad,40,mvsas,1)
endef
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index ef41d6f700..233106718b 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -64,7 +64,7 @@ $(eval $(call KernelPackage,crypto-manager))
define KernelPackage/crypto-user
TITLE:=CryptoAPI userspace interface
- DEPENDS:=+kmod-crypto-hash +kmod-crypto-manager @!LINUX_2_6_30&&!LINUX_2_6_31&&!LINUX_2_6_32&&!LINUX_2_6_36&&!LINUX_2_6_37
+ DEPENDS:=+kmod-crypto-hash +kmod-crypto-manager @!LINUX_2_6_37
KCONFIG:= \
CONFIG_CRYPTO_USER_API \
CONFIG_CRYPTO_USER_API_HASH \
diff --git a/package/kernel/modules/firewire.mk b/package/kernel/modules/firewire.mk
index 43d16c7eca..34edf0c511 100644
--- a/package/kernel/modules/firewire.mk
+++ b/package/kernel/modules/firewire.mk
@@ -7,89 +7,6 @@
FIREWIRE_MENU:=FireWire support
-define firewiredep
- SUBMENU:=$(FIREWIRE_MENU)
- DEPENDS:=kmod-ieee1394 $(1)
-endef
-
-
-define KernelPackage/ieee1394
- SUBMENU:=$(FIREWIRE_MENU)
- TITLE:=Support for FireWire (old stack)
- DEPENDS:=@PCI_SUPPORT @LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36
- KCONFIG:=CONFIG_IEEE1394
- FILES:=$(LINUX_DIR)/drivers/ieee1394/ieee1394.ko
- AUTOLOAD:=$(call AutoLoad,20,ieee1394)
-endef
-
-define KernelPackage/ieee1394/description
- Kernel support for FireWire (old stack)
-endef
-
-$(eval $(call KernelPackage,ieee1394))
-
-
-define KernelPackage/ohci1394
- $(call firewiredep,)
- TITLE:=Support for OHCI-1394 controllers
- KCONFIG:= CONFIG_IEEE1394_OHCI1394
- FILES:=$(LINUX_DIR)/drivers/ieee1394/ohci1394.ko
- AUTOLOAD:=$(call AutoLoad,50,ohci1394)
-endef
-
-define KernelPackage/ohci1394/description
- Kernel support for FireWire OHCI-1394 controllers
-endef
-
-$(eval $(call KernelPackage,ohci1394))
-
-
-define KernelPackage/sbp2
- $(call firewiredep,kmod-ohci1394)
- TITLE:=Support for SBP-2 devices over FireWire
- KCONFIG:= \
- CONFIG_IEEE1394_SBP2 \
- CONFIG_IEEE1394_SBP2_PHYS_DMA=n
- FILES:=$(LINUX_DIR)/drivers/ieee1394/sbp2.ko
- AUTOLOAD:=$(call AutoLoad,50,sbp2)
-endef
-
-define KernelPackage/sbp2/description
- Kernel support for SBP-2 devices over FireWire
-endef
-
-$(eval $(call KernelPackage,sbp2))
-
-
-define KernelPackage/raw1394
- $(call firewiredep,kmod-ohci1394)
- TITLE:=Support for Raw I/O for FireWire devices
- KCONFIG:=CONFIG_IEEE1394_RAWIO
- FILES:=$(LINUX_DIR)/drivers/ieee1394/raw1394.ko
- AUTOLOAD:=$(call AutoLoad,50,raw1394)
-endef
-
-define KernelPackage/raw1394/description
- Kernel support for FireWire Raw I/O
-endef
-
-$(eval $(call KernelPackage,raw1394))
-
-
-define KernelPackage/video1394
- $(call firewiredep,kmod-ohci1394)
- TITLE:=Support for FireWire video
- KCONFIG:=CONFIG_IEEE1394_VIDEO1394
- FILES:=$(LINUX_DIR)/drivers/ieee1394/video1394.ko
- AUTOLOAD:=$(call AutoLoad,50,video1394)
-endef
-
-define KernelPackage/video1394/description
- Kernel support for FireWire video
-endef
-
-$(eval $(call KernelPackage,video1394))
-
define KernelPackage/firewire
SUBMENU:=$(FIREWIRE_MENU)
@@ -146,7 +63,7 @@ $(eval $(call KernelPackage,firewire-sbp2))
define KernelPackage/firewire-net
SUBMENU:=$(FIREWIRE_MENU)
TITLE:=Support for IP networking over FireWire
- DEPENDS:=kmod-firewire @!LINUX_2_6_30
+ DEPENDS:=kmod-firewire
KCONFIG:=CONFIG_FIREWIRE_NET
FILES:=$(LINUX_DIR)/drivers/firewire/firewire-net.ko
AUTOLOAD:=$(call AutoLoad,50,firewire-net)
diff --git a/package/kernel/modules/fs.mk b/package/kernel/modules/fs.mk
index b8bfa899fd..1d65f66f0a 100644
--- a/package/kernel/modules/fs.mk
+++ b/package/kernel/modules/fs.mk
@@ -25,7 +25,7 @@ $(eval $(call KernelPackage,fs-autofs4))
define KernelPackage/fs-btrfs
SUBMENU:=$(FS_MENU)
TITLE:=BTRFS filesystem support
- DEPENDS:=+kmod-lib-crc32c +!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37):kmod-lib-lzo +kmod-lib-zlib
+ DEPENDS:=+kmod-lib-crc32c +!(LINUX_2_6_37):kmod-lib-lzo +kmod-lib-zlib
KCONFIG:=\
CONFIG_BTRFS_FS \
CONFIG_BTRFS_FS_POSIX_ACL=n \
@@ -53,12 +53,12 @@ define KernelPackage/fs-cifs
AUTOLOAD:=$(call AutoLoad,30,cifs)
$(call AddDepends/nls)
DEPENDS+= \
- +!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36):kmod-crypto-arc4 \
- +!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36):kmod-crypto-hmac \
- +!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36):kmod-crypto-md5 \
- +!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37):kmod-crypto-md4 \
- +!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-crypto-des \
- +!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-crypto-ecb
+ +kmod-crypto-arc4 \
+ +kmod-crypto-hmac \
+ +kmod-crypto-md5 \
+ +!(LINUX_2_6_37):kmod-crypto-md4 \
+ +!(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-crypto-des \
+ +!(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-crypto-ecb
endef
define KernelPackage/fs-cifs/description
@@ -83,42 +83,6 @@ endef
$(eval $(call KernelPackage,fs-exportfs))
-define KernelPackage/fs-ext2
- SUBMENU:=$(FS_MENU)
- TITLE:=EXT2 filesystem support
- KCONFIG:=CONFIG_EXT2_FS
- DEPENDS:=@LINUX_2_6_30||LINUX_2_6_31
- FILES:=$(LINUX_DIR)/fs/ext2/ext2.ko
- AUTOLOAD:=$(call AutoLoad,32,ext2,1)
-endef
-
-define KernelPackage/fs-ext2/description
- Kernel module for EXT2 filesystem support
-endef
-
-$(eval $(call KernelPackage,fs-ext2,1))
-
-
-define KernelPackage/fs-ext3
- SUBMENU:=$(FS_MENU)
- TITLE:=EXT3 filesystem support
- KCONFIG:= \
- CONFIG_EXT3_FS \
- CONFIG_JBD
- DEPENDS:=@LINUX_2_6_30||LINUX_2_6_31
- FILES:= \
- $(LINUX_DIR)/fs/ext3/ext3.ko \
- $(LINUX_DIR)/fs/jbd/jbd.ko
- AUTOLOAD:=$(call AutoLoad,31,jbd ext3,1)
-endef
-
-define KernelPackage/fs-ext3/description
- Kernel module for EXT3 filesystem support
-endef
-
-$(eval $(call KernelPackage,fs-ext3))
-
-
define KernelPackage/fs-ext4
SUBMENU:=$(FS_MENU)
TITLE:=EXT4 filesystem support
diff --git a/package/kernel/modules/lib.mk b/package/kernel/modules/lib.mk
index b260541953..cf21d49fdb 100644
--- a/package/kernel/modules/lib.mk
+++ b/package/kernel/modules/lib.mk
@@ -55,7 +55,7 @@ $(eval $(call KernelPackage,lib-crc7))
define KernelPackage/lib-crc8
SUBMENU:=$(LIB_MENU)
TITLE:=CRC8 support
- DEPENDS:= @!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39||LINUX_3_0)
+ DEPENDS:= @!(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39||LINUX_3_0)
KCONFIG:=CONFIG_CRC8
FILES:=$(LINUX_DIR)/lib/crc8.ko
AUTOLOAD:=$(call AutoLoad,20,crc8)
@@ -150,7 +150,7 @@ $(eval $(call KernelPackage,lib-zlib))
define KernelPackage/lib-cordic
SUBMENU:=$(LIB_MENU)
TITLE:=Cordic function support
- DEPENDS:= @!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39||LINUX_3_0)
+ DEPENDS:= @!(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39||LINUX_3_0)
KCONFIG:=CONFIG_CORDIC
FILES:=$(LINUX_DIR)/lib/cordic.ko
AUTOLOAD:=$(call AutoLoad,20,cordic)
diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index bac681b75c..06abc69af3 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -561,7 +561,7 @@ $(eval $(call KernelPackage,pppoa))
define KernelPackage/pptp
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=PPtP support
- DEPENDS:=kmod-ppp +kmod-gre @!LINUX_2_6_30&&!LINUX_2_6_31&&!LINUX_2_6_32&&!LINUX_2_6_36
+ DEPENDS:=kmod-ppp +kmod-gre
KCONFIG:=CONFIG_PPTP
ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.2)),1)
FILES:=$(LINUX_DIR)/drivers/net/ppp/pptp.ko
@@ -577,7 +577,7 @@ $(eval $(call KernelPackage,pptp))
define KernelPackage/pppol2tp
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=PPPoL2TP support
- DEPENDS:=kmod-ppp +kmod-pppoe +!LINUX_2_6_30&&!LINUX_2_6_31&&!LINUX_2_6_32:kmod-l2tp
+ DEPENDS:=kmod-ppp +kmod-pppoe +kmod-l2tp
KCONFIG:=CONFIG_PPPOL2TP
ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.35)),1)
FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ppp.ko
@@ -744,7 +744,6 @@ $(eval $(call KernelPackage,pktgen))
define KernelPackage/l2tp
SUBMENU:=$(NETWORK_SUPPORT_MENU)
- DEPENDS:=@!LINUX_2_6_30&&!LINUX_2_6_31&&!LINUX_2_6_32
TITLE:=Layer Two Tunneling Protocol (L2TP)
KCONFIG:=CONFIG_L2TP \
CONFIG_L2TP_V3=y \
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 06f1f78d3f..1f61da831a 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -142,7 +142,7 @@ $(eval $(call KernelPackage,eeprom-at25))
define KernelPackage/gpio-cs5535
SUBMENU:=$(OTHER_MENU)
TITLE:=AMD CS5535/CS5536 GPIO driver
- DEPENDS:=@TARGET_x86 @LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37
+ DEPENDS:=@TARGET_x86 @LINUX_2_6_37
KCONFIG:=CONFIG_CS5535_GPIO
FILES:=$(LINUX_DIR)/drivers/char/cs5535_gpio.ko
AUTOLOAD:=$(call AutoLoad,50,cs5535_gpio)
@@ -158,7 +158,7 @@ $(eval $(call KernelPackage,gpio-cs5535))
define KernelPackage/gpio-cs5535-new
SUBMENU:=$(OTHER_MENU)
TITLE:=AMD CS5535/CS5536 GPIO driver with improved sysfs support
- DEPENDS:=@TARGET_x86 +kmod-cs5535-mfd @!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32)
+ DEPENDS:=@TARGET_x86 +kmod-cs5535-mfd
KCONFIG:=CONFIG_GPIO_CS5535
ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.1.0)),1)
FILES:=$(LINUX_DIR)/drivers/gpio/gpio-cs5535.ko
@@ -342,7 +342,7 @@ $(eval $(call KernelPackage,input-gpio-keys))
define KernelPackage/input-gpio-keys-polled
SUBMENU:=$(OTHER_MENU)
TITLE:=Polled GPIO key support
- DEPENDS:=@GPIO_SUPPORT @!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_34||LINUX_2_6_35||LINUX_2_6_36) +kmod-input-polldev
+ DEPENDS:=@GPIO_SUPPORT +kmod-input-polldev
KCONFIG:= \
CONFIG_KEYBOARD_GPIO_POLLED \
CONFIG_INPUT_KEYBOARD=y
@@ -488,16 +488,9 @@ define KernelPackage/rfkill
CONFIG_RFKILL \
CONFIG_RFKILL_INPUT=y \
CONFIG_RFKILL_LEDS=y
-ifeq ($(CONFIG_LINUX_2_6_30),)
FILES:= \
$(LINUX_DIR)/net/rfkill/rfkill.ko
AUTOLOAD:=$(call AutoLoad,20,rfkill)
-else
- FILES:= \
- $(LINUX_DIR)/net/rfkill/rfkill.ko \
- $(LINUX_DIR)/net/rfkill/rfkill-input.ko
- AUTOLOAD:=$(call AutoLoad,20,rfkill rfkill-input)
-endif
$(call SetDepends/rfkill)
endef
@@ -768,7 +761,7 @@ $(eval $(call KernelPackage,pwm-gpio))
define KernelPackage/rtc-core-2.6
SUBMENU:=$(OTHER_MENU)
- DEPENDS:=@LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39
+ DEPENDS:=@(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39)
TITLE:=Real Time Clock class support
KCONFIG:=CONFIG_RTC_CLASS
FILES:=$(LINUX_DIR)/drivers/rtc/rtc-core.ko
@@ -783,7 +776,7 @@ $(eval $(call KernelPackage,rtc-core-2.6))
define KernelPackage/rtc-core-3.x
SUBMENU:=$(OTHER_MENU)
- DEPENDS:=@!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39)
+ DEPENDS:=@!(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39)
TITLE:=Real Time Clock class support
KCONFIG:=CONFIG_RTC_CLASS=y
endef
@@ -883,7 +876,7 @@ $(eval $(call KernelPackage,mtdtests))
define KernelPackage/nand
SUBMENU:=$(OTHER_MENU)
TITLE:=NAND flash support
- DEPENDS:=@!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39)
+ DEPENDS:=@!(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39)
KCONFIG:=CONFIG_MTD_NAND \
CONFIG_MTD_NAND_IDS \
CONFIG_MTD_NAND_ECC
@@ -904,7 +897,7 @@ $(eval $(call KernelPackage,nand))
define KernelPackage/nandsim
SUBMENU:=$(OTHER_MENU)
TITLE:=NAND simulator
- DEPENDS:=@!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39) +kmod-nand
+ DEPENDS:=@!(LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39) +kmod-nand
KCONFIG:=CONFIG_MTD_NAND_NANDSIM
FILES:=$(LINUX_DIR)/drivers/mtd/nand/nandsim.ko
endef
diff --git a/package/kernel/modules/virtual.mk b/package/kernel/modules/virtual.mk
index 05eb4965b6..6c907a9b6e 100644
--- a/package/kernel/modules/virtual.mk
+++ b/package/kernel/modules/virtual.mk
@@ -166,7 +166,7 @@ $(eval $(call KernelPackage,xen-netdev))
define KernelPackage/xen-pcidev
SUBMENU:=$(VIRTUAL_MENU)
TITLE:=Xen PCI device frontend
- DEPENDS:=@TARGET_x86_xen_domu @!LINUX_2_6_30&&!LINUX_2_6_31&&!LINUX_2_6_32&&!LINUX_2_6_36
+ DEPENDS:=@TARGET_x86_xen_domu
KCONFIG:=CONFIG_XEN_PCIDEV_FRONTEND
FILES:=$(LINUX_DIR)/drivers/xen/platform-pci.ko
AUTOLOAD:=$(call AutoLoad,10,xen-pcifront)