aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2011-10-28 19:16:21 +0000
committerNicolas Thill <nico@openwrt.org>2011-10-28 19:16:21 +0000
commit897ab36e93127a9e27f36a4c2d34b30e6eb70834 (patch)
treed3dc2a7de6867f5347d41603ff48d3fa832d0e28 /package/kernel
parentc824c76aae78d043251d84518826f6d025c55842 (diff)
downloadupstream-897ab36e93127a9e27f36a4c2d34b30e6eb70834.tar.gz
upstream-897ab36e93127a9e27f36a4c2d34b30e6eb70834.tar.bz2
upstream-897ab36e93127a9e27f36a4c2d34b30e6eb70834.zip
package/kernel: fix kmod-fs-cifs dependencies (closes: #9381, #10055)
SVN-Revision: 28661
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/fs.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/kernel/modules/fs.mk b/package/kernel/modules/fs.mk
index 6c253c773d..84d2311e7e 100644
--- a/package/kernel/modules/fs.mk
+++ b/package/kernel/modules/fs.mk
@@ -48,6 +48,14 @@ define KernelPackage/fs-cifs
FILES:=$(LINUX_DIR)/fs/cifs/cifs.ko
AUTOLOAD:=$(call AutoLoad,30,cifs)
$(call AddDepends/nls)
+ DEPENDS+= \
+ !(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36):kmod-crypto-core \
+ !(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36):kmod-crypto-arc4 \
+ !(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36):kmod-crypto-hmac \
+ !(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36):kmod-crypto-md5 \
+ !(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37):kmod-crypto-md4 \
+ !(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-crypto-des \
+ !(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-crypto-ecb
endef
define KernelPackage/fs-cifs/description