aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorAnsuel Smith <ansuelsmth@gmail.com>2020-08-09 16:31:05 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-08-13 02:12:12 +0200
commit87e92d50e577851743663763bc749fe18aa294c7 (patch)
tree3b0d0fb9c9e3c7a95c5bba21cd8e2b4b3a7e40a7 /package/kernel
parent35d1f05094fc6aae0ad3f71d743815d002edc6ee (diff)
downloadupstream-87e92d50e577851743663763bc749fe18aa294c7.tar.gz
upstream-87e92d50e577851743663763bc749fe18aa294c7.tar.bz2
upstream-87e92d50e577851743663763bc749fe18aa294c7.zip
kernel: usb: move phy-qcom-ipq806x-usb to ipq806x modules.mk
This driver is only used by ipq806x SoCs. Move it there and drop dependency from ipq40xx since it's not used anywere. Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com> [rebase on changes to previous patches] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> Tested-by: Paul Blazejowski <paulb@blazebox.homeip.net> [R7800]
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/usb.mk18
1 files changed, 0 insertions, 18 deletions
diff --git a/package/kernel/linux/modules/usb.mk b/package/kernel/linux/modules/usb.mk
index 5db0244968..fc411c5a54 100644
--- a/package/kernel/linux/modules/usb.mk
+++ b/package/kernel/linux/modules/usb.mk
@@ -70,24 +70,6 @@ endef
$(eval $(call KernelPackage,usb-phy-nop))
-define KernelPackage/phy-qcom-ipq806x-usb
- TITLE:=Qualcomm IPQ806x DWC3 USB PHY driver
- DEPENDS:=@(TARGET_ipq40xx||TARGET_ipq806x)
- KCONFIG:= CONFIG_PHY_QCOM_IPQ806X_USB
- FILES:= \
- $(LINUX_DIR)/drivers/phy/qualcomm/phy-qcom-ipq806x-usb.ko
- AUTOLOAD:=$(call AutoLoad,45,phy-qcom-ipq806x-usb,1)
- $(call AddDepends/usb)
-endef
-
-define KernelPackage/phy-qcom-ipq806x-usb/description
- This driver provides support for the integrated DesignWare
- USB3 IP Core within the QCOM SoCs.
-endef
-
-$(eval $(call KernelPackage,phy-qcom-ipq806x-usb))
-
-
define KernelPackage/phy-ath79-usb
TITLE:=Support for ATH79 USB PHY
KCONFIG:=CONFIG_PHY_AR7100_USB \