aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-01-23 16:39:31 +0000
committerNicolas Thill <nico@openwrt.org>2010-01-23 16:39:31 +0000
commit86bb5e14191480090a50304e3bd09d0f065418af (patch)
treec0cb9523fd803bdf0f5b8c02353e1c073f376580 /package/kernel
parentc3a65ffc05604ec20f192c3df033bb1ce915e388 (diff)
downloadupstream-86bb5e14191480090a50304e3bd09d0f065418af.tar.gz
upstream-86bb5e14191480090a50304e3bd09d0f065418af.tar.bz2
upstream-86bb5e14191480090a50304e3bd09d0f065418af.zip
[package] add explicit dependency on kmod-crypto-core when required (closes: #6557)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19291 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/netsupport.mk2
-rw-r--r--package/kernel/modules/wireless.mk4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index 5b58aae034..e19afcc03f 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -505,7 +505,7 @@ $(eval $(call KernelPackage,ipoa))
define KernelPackage/mppe
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=Microsoft PPP compression/encryption
- DEPENDS:=kmod-ppp +kmod-crypto-arc4 +kmod-crypto-sha1
+ DEPENDS:=kmod-ppp +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-sha1
KCONFIG:= \
CONFIG_PPP_MPPE_MPPC \
CONFIG_PPP_MPPE
diff --git a/package/kernel/modules/wireless.mk b/package/kernel/modules/wireless.mk
index 19f07408c1..25e2286f16 100644
--- a/package/kernel/modules/wireless.mk
+++ b/package/kernel/modules/wireless.mk
@@ -12,7 +12,7 @@ WIRELESS_MENU:=Wireless Drivers
define KernelPackage/ieee80211
SUBMENU:=$(WIRELESS_MENU)
TITLE:=802.11 Networking stack
- DEPENDS:=+kmod-crypto-arc4 +kmod-crypto-aes +kmod-crypto-michael-mic @LINUX_2_4||@LINUX_2_6_21||LINUX_2_6_25
+ DEPENDS:=+kmod-crypto-core kmod-crypto-arc4 +kmod-crypto-aes +kmod-crypto-michael-mic @LINUX_2_4||@LINUX_2_6_21||LINUX_2_6_25
KCONFIG:= \
CONFIG_IEEE80211 \
CONFIG_IEEE80211_CRYPT_WEP \
@@ -83,7 +83,7 @@ $(eval $(call KernelPackage,lib80211))
define KernelPackage/net-libipw
SUBMENU:=$(WIRELESS_MENU)
TITLE:=libipw for ipw2100 and ipw2200
- DEPENDS:=@PCI_SUPPORT +kmod-crypto-arc4 +kmod-crypto-aes +kmod-crypto-michael-mic +kmod-lib80211 @LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32
+ DEPENDS:=@PCI_SUPPORT +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-aes +kmod-crypto-michael-mic +kmod-lib80211 @LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32
KCONFIG:=CONFIG_LIBIPW
FILES:=$(LINUX_DIR)/drivers/net/wireless/ipw2x00/libipw.$(LINUX_KMOD_SUFFIX)
AUTOLOAD:=$(call AutoLoad,49,libipw)