aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorMartin Schiller <ms@dev.tdt.de>2017-11-22 14:28:41 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-11-22 20:49:04 +0100
commit7ffeecd6acb2472dd777ae4c5c418f400ddf0b8e (patch)
tree24634dfb6670d80b890e7269b6edccd6f551eead /package/kernel
parent62ede4f78389c313a8004e79330a7d055eda2f7d (diff)
downloadupstream-7ffeecd6acb2472dd777ae4c5c418f400ddf0b8e.tar.gz
upstream-7ffeecd6acb2472dd777ae4c5c418f400ddf0b8e.tar.bz2
upstream-7ffeecd6acb2472dd777ae4c5c418f400ddf0b8e.zip
kernel: add it87-wdt watchdog timer module
The module parameters "nogameport=1" and "nocir=1" are needed, because this is not supported on recent chips and doesn't really tell if the system is stable. As this features will already be removed in linux-4.13 or newer, this module parameters can be removed in the future. Signed-off-by: Martin Schiller <ms@dev.tdt.de>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/other.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 1d07a16420..8e2f3a012d 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -1031,3 +1031,21 @@ define KernelPackage/itco-wdt/description
endef
$(eval $(call KernelPackage,itco-wdt))
+
+
+define KernelPackage/it87-wdt
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=ITE IT87 Watchdog Timer
+ KCONFIG:=CONFIG_IT87_WDT
+ FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/it87_wdt.ko
+ AUTOLOAD:=$(call AutoLoad,50,it87-wdt,1)
+ MODPARAMS.it87-wdt:= \
+ nogameport=1 \
+ nocir=1
+endef
+
+define KernelPackage/it87-wdt/description
+ Kernel module for ITE IT87 Watchdog Timer
+endef
+
+$(eval $(call KernelPackage,it87-wdt))