aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorThomas Langer <tlanger@maxlinear.com>2022-07-29 18:36:00 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2022-11-05 22:55:36 +0100
commit7ee55d82fc521fb89dc05ea830f3c85f3d07a7ba (patch)
tree346dfee21daf783fa425838f14947c8e6cc8d054 /package/kernel
parent31fd96bdbd6ff89e031bb7f89ac21c9bd63127cd (diff)
downloadupstream-7ee55d82fc521fb89dc05ea830f3c85f3d07a7ba.tar.gz
upstream-7ee55d82fc521fb89dc05ea830f3c85f3d07a7ba.tar.bz2
upstream-7ee55d82fc521fb89dc05ea830f3c85f3d07a7ba.zip
kernel: netsupport: Extract sched-prio and sched-red
Extract the kmod-sched-prio and kmod-sched-red kernel modules from the big kmod-sched package. This allows adding the two kernel modules to OpenWrt without adding the kmod-sched and all its depdnecy. Signed-off-by: Thomas Langer <tlanger@maxlinear.com> Signed-off-by: Hauke Mehrtens <hmehrtens@maxlinear.com> (cherry picked from commit 0e3911b6084ac596a3da6b1a255776e44331beef)
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/netsupport.mk36
1 files changed, 33 insertions, 3 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index c9afe3b2a6..2eeec94230 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -906,6 +906,38 @@ endef
$(eval $(call KernelPackage,sched-mqprio))
+define KernelPackage/sched-prio
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=Multi Band Priority Queueing (PRIO)
+ DEPENDS:=+kmod-sched-core
+ KCONFIG:=CONFIG_NET_SCH_PRIO
+ FILES:=$(LINUX_DIR)/net/sched/sch_prio.ko
+ AUTOLOAD:=$(call AutoProbe,sch_prio)
+endef
+
+define KernelPackage/sched-prio/description
+ PRIO algorithm Configuration
+endef
+
+$(eval $(call KernelPackage,sched-prio))
+
+
+define KernelPackage/sched-red
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=Random Early Detection (RED)
+ DEPENDS:=+kmod-sched-core
+ KCONFIG:=CONFIG_NET_SCH_RED
+ FILES:=$(LINUX_DIR)/net/sched/sch_red.ko
+ AUTOLOAD:=$(call AutoProbe,sch_red)
+endef
+
+define KernelPackage/sched-red/description
+ Random Early Detection (RED) algorithm Configuration
+endef
+
+$(eval $(call KernelPackage,sched-red))
+
+
define KernelPackage/bpf-test
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=Test Berkeley Packet Filter functionality
@@ -916,7 +948,7 @@ endef
$(eval $(call KernelPackage,bpf-test))
-SCHED_MODULES_EXTRA = sch_codel sch_dsmark sch_gred sch_multiq sch_prio sch_red sch_sfq sch_teql sch_fq sch_pie act_police act_ipt act_pedit act_simple act_csum em_cmp em_nbyte em_meta em_text
+SCHED_MODULES_EXTRA = sch_codel sch_dsmark sch_gred sch_multiq sch_sfq sch_teql sch_fq sch_pie act_police act_ipt act_pedit act_simple act_csum em_cmp em_nbyte em_meta em_text
SCHED_FILES_EXTRA = $(foreach mod,$(SCHED_MODULES_EXTRA),$(LINUX_DIR)/net/sched/$(mod).ko)
define KernelPackage/sched
@@ -928,8 +960,6 @@ define KernelPackage/sched
CONFIG_NET_SCH_DSMARK \
CONFIG_NET_SCH_GRED \
CONFIG_NET_SCH_MULTIQ \
- CONFIG_NET_SCH_PRIO \
- CONFIG_NET_SCH_RED \
CONFIG_NET_SCH_SFQ \
CONFIG_NET_SCH_TEQL \
CONFIG_NET_SCH_FQ \