aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorChristian Lamparter <chunkeey@gmail.com>2023-05-21 19:05:03 +0200
committerDaniel Golle <daniel@makrotopia.org>2023-05-24 19:25:44 +0100
commit7613efde8eaa17a21d4b24d8691d981673513536 (patch)
treec74446fe091ee1dcac2060490de85e6a631dac45 /package/kernel
parente22fba1694376fd1396fe7a7aaedb1273c66f094 (diff)
downloadupstream-7613efde8eaa17a21d4b24d8691d981673513536.tar.gz
upstream-7613efde8eaa17a21d4b24d8691d981673513536.tar.bz2
upstream-7613efde8eaa17a21d4b24d8691d981673513536.zip
uml: exclude some /arch/x86 optimizations
The x86_64 UML target wants to include SSSE3 optimized crypto code which lives under /arch/x86/crypto. However, these are not built and this causes an error. | ERROR: module '[...]/arch/x86/crypto/sha512-ssse3.ko' is missing. | make[3]: *** [modules/crypto.mk:990: [...]/kmod-crypto-sha512_5.15.112-1_x86_64.ipk] Error 1 Signed-off-by: Christian Lamparter <chunkeey@gmail.com> (cherry picked from commit 959563fb813890e478bf0a51523cd84d54b9af91) Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/crypto.mk6
1 files changed, 6 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index a3785d26fd..248b4d68f9 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -897,10 +897,12 @@ define KernelPackage/crypto-sha1/mpc85xx
AUTOLOAD+=$(call AutoLoad,09,sha1-ppc-spe)
endef
+ifndef CONFIG_TARGET_uml
define KernelPackage/crypto-sha1/x86_64
FILES+=$(LINUX_DIR)/arch/x86/crypto/sha1-ssse3.ko
AUTOLOAD+=$(call AutoLoad,09,sha1-ssse3)
endef
+endif
ifdef KernelPackage/crypto-sha1/$(ARCH)
KernelPackage/crypto-sha1/$(CRYPTO_TARGET)=\
@@ -935,10 +937,12 @@ define KernelPackage/crypto-sha256/mpc85xx
AUTOLOAD+=$(call AutoLoad,09,sha256-ppc-spe)
endef
+ifndef CONFIG_TARGET_uml
define KernelPackage/crypto-sha256/x86_64
FILES+=$(LINUX_DIR)/arch/x86/crypto/sha256-ssse3.ko
AUTOLOAD+=$(call AutoLoad,09,sha256-ssse3)
endef
+endif
ifdef KernelPackage/crypto-sha256/$(ARCH)
KernelPackage/crypto-sha256/$(CRYPTO_TARGET)=\
@@ -977,10 +981,12 @@ endef
KernelPackage/crypto-sha512/tegra=$(KernelPackage/crypto-sha512/arm)
+ifndef CONFIG_TARGET_uml
define KernelPackage/crypto-sha512/x86_64
FILES+=$(LINUX_DIR)/arch/x86/crypto/sha512-ssse3.ko
AUTOLOAD+=$(call AutoLoad,09,sha512-ssse3)
endef
+endif
ifdef KernelPackage/crypto-sha512/$(ARCH)
KernelPackage/crypto-sha512/$(CRYPTO_TARGET)=\