aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-09-05 23:16:24 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-09-05 23:16:24 +0000
commit75ffc6d36758ca335814d10bf45c0cf42d3b2430 (patch)
tree2a2ca490935581f79b18feacef56e079a1113ac3 /package/kernel
parent1553660de2bfffe65bee0a3be934b2c2e4e0f48a (diff)
downloadupstream-75ffc6d36758ca335814d10bf45c0cf42d3b2430.tar.gz
upstream-75ffc6d36758ca335814d10bf45c0cf42d3b2430.tar.bz2
upstream-75ffc6d36758ca335814d10bf45c0cf42d3b2430.zip
kernel: add VirtIO device support Add support for VirtIO-based paravirtualized devices used by various virtualization platforms.
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be> SVN-Revision: 22943
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/virtual.mk48
1 files changed, 48 insertions, 0 deletions
diff --git a/package/kernel/modules/virtual.mk b/package/kernel/modules/virtual.mk
index f988c163c9..c129820f83 100644
--- a/package/kernel/modules/virtual.mk
+++ b/package/kernel/modules/virtual.mk
@@ -7,6 +7,54 @@
VIRTUAL_MENU:=Virtualization Support
+
+define KernelPackage/virtio-balloon
+ SUBMENU:=$(VIRTUAL_MENU)
+ TITLE:=VirtIO balloon driver
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_VIRTIO_BALLOON
+ FILES:=$(LINUX_DIR)/drivers/virtio/virtio_balloon.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,06,virtio-balloon)
+endef
+
+define KernelPackage/virtio-balloon/description
+ Kernel module for VirtIO memory ballooning support
+endef
+
+$(eval $(call KernelPackage,virtio-balloon))
+
+
+define KernelPackage/virtio-net
+ SUBMENU:=$(VIRTUAL_MENU)
+ TITLE:=VirtIO network driver
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_VIRTIO_NET
+ FILES:=$(LINUX_DIR)/drivers/net/virtio_net.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,50,virtio_net)
+endef
+
+define KernelPackage/virtio-net/description
+ Kernel module for the VirtIO paravirtualized network device
+endef
+
+$(eval $(call KernelPackage,virtio-net))
+
+
+define KernelPackage/virtio-random
+ SUBMENU:=$(VIRTUAL_MENU)
+ TITLE:=VirtIO Random Number Generator support
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_HW_RANDOM_VIRTIO
+ FILES:=$(LINUX_DIR)/drivers/char/hw_random/virtio-rng.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,09,virtio-rng)
+endef
+
+define KernelPackage/virtio-random/description
+ Kernel module for the VirtIO Random Number Generator
+endef
+
+$(eval $(call KernelPackage,virtio-random))
+
define KernelPackage/xen-fs
SUBMENU:=$(VIRTUAL_MENU)
TITLE:=Xen filesystem