aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2016-12-16 17:32:10 +0100
committerFelix Fietkau <nbd@nbd.name>2016-12-16 22:39:22 +0100
commit720b99215da295a2e7b4acdef30b58bec6acedc2 (patch)
tree73ac1ea4ae91e5d6b2bfcfbc7bb71434d81be922 /package/kernel
parent4921760a4531bff87c3928a622a5c9e50b9f56d3 (diff)
downloadupstream-720b99215da295a2e7b4acdef30b58bec6acedc2.tar.gz
upstream-720b99215da295a2e7b4acdef30b58bec6acedc2.tar.bz2
upstream-720b99215da295a2e7b4acdef30b58bec6acedc2.zip
treewide: clean up download hashes
Replace *MD5SUM with *HASH, replace MD5 hashes with SHA256 Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/acx-mac80211/Makefile19
-rw-r--r--package/kernel/ar7-atm/Makefile6
-rw-r--r--package/kernel/ath10k-ct/Makefile1
-rw-r--r--package/kernel/brcm2708-gpu-fw/Makefile12
-rw-r--r--package/kernel/broadcom-wl/Makefile9
-rw-r--r--package/kernel/ep80579-drivers/Makefile2
-rw-r--r--package/kernel/kmod-sched-cake/Makefile2
-rw-r--r--package/kernel/lantiq/ltq-adsl-fw/Makefile2
-rw-r--r--package/kernel/lantiq/ltq-adsl/Makefile2
-rw-r--r--package/kernel/lantiq/ltq-ifxos/Makefile2
-rw-r--r--package/kernel/lantiq/ltq-tapi/Makefile2
-rw-r--r--package/kernel/lantiq/ltq-vdsl-mei/Makefile2
-rw-r--r--package/kernel/lantiq/ltq-vdsl/Makefile2
-rw-r--r--package/kernel/lantiq/ltq-vmmc/Makefile18
-rw-r--r--package/kernel/mac80211/Makefile28
-rw-r--r--package/kernel/mt76/Makefile1
-rw-r--r--package/kernel/mwlwifi/Makefile1
17 files changed, 59 insertions, 52 deletions
diff --git a/package/kernel/acx-mac80211/Makefile b/package/kernel/acx-mac80211/Makefile
index d295b466b8..fb11188076 100644
--- a/package/kernel/acx-mac80211/Makefile
+++ b/package/kernel/acx-mac80211/Makefile
@@ -14,6 +14,7 @@ PKG_VERSION:=20140216
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_MIRROR_HASH:=2297d68dc3ff439b387bffba19d1469336bde910b3b3ff8b785df926e811156e
PKG_SOURCE_URL:=http://git.code.sf.net/p/acx100/acx-mac80211
PKG_SOURCE_PROTO:=git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
@@ -118,55 +119,55 @@ endef
define Download/tiacx100
FILE:=tiacx100
URL:=http://acx100.erley.org/fw/acx100_1.9.8.b/
- MD5SUM:=24a54fd30f7658fcbffc825b0dd7aa5b
+ HASH:=4f05913c940c2455b267545b12d93ad81fa5eebb0cbee22a2c7588c50525b4f0
endef
define Download/tiacx100r0d
FILE:=tiacx100r0D
URL:=http://acx100.erley.org/fw/acx100_1.9.8.b/
- MD5SUM:=1c7413e7b0be4ef7d1e424a132e17fab
+ HASH:=6a4a7fbb24a328a88261bc2a507b2a0bf63c91e831e3f1a8caa4f6599b2215e6
endef
define Download/tiacx100r11
FILE:=tiacx100r11
URL:=http://acx100.erley.org/fw/acx100_1.9.8.b/
- MD5SUM:=a150750ad33c512edc4afee5270b37cb
+ HASH:=e005a93a0b463e01edba2b79038b54c29a7932efee61c851a2ac644b8a4e5dd4
endef
define Download/tiacx100r15
FILE:=tiacx100r15
URL:=http://acx100.erley.org/fw/acx100_1.9.8.b/
- MD5SUM:=c99d01d4fcf0d6cc00441aff60690be4
+ HASH:=c6f40bead5ef45720e2d72bbe4d998367c2c7857eb7716234aedeb2ad98bcdde
endef
define Download/tiacx111c16
FILE:=tiacx111c16
URL:=http://acx100.erley.org/fw/acx111_2.3.1.31/
- MD5SUM:=7026826460376f6b174f9225bd7781b9
+ HASH:=cc6108d577ebc55b924ff6bab44eeee3456d284c63819277cb5460338b2f1bd7
endef
define Download/tiacx111c16_1
FILE:=tiacx111c16_1.2.1_34
URL:=http://sites.google.com/site/atorkhov/files/
- MD5SUM:=fcd07de4b25e1d2aaf3b78b27c5b7ee9
+ HASH:=672ed9d02565ab44da450c52f0ced3be99a3a3901f73454455da8e1f98ada220
endef
define Download/tiacx111c17
FILE:=tiacx111c17
URL:=http://acx100.erley.org/fw/acx111_2.3.1.31/
- MD5SUM:=95552544ca6d2b4e8c6aeb80b8ae7fdf
+ HASH:=2bb900a5886dbea2d3504623d9f3ac8abbb2e9fdfcf0fe233e77951dff748a40
endef
define Download/tiacx111c19
FILE:=tiacx111c19
URL:=http://acx100.erley.org/fw/acx111_2.3.1.31/
- MD5SUM:=a1fa9681e297b4e36e257090fc12265a
+ HASH:=383d86a8cfddf92400d661b4e43a9b855350fa656edd4f75b4aff7fab2d00e90
endef
define Download/tiacx111usbc1b
FILE:=tiacx111usbc1B
URL:=http://acx100.erley.org/fw/acx111_2.4.0.70-USB/
- MD5SUM:=c4edecd912b2417779d0b65e3a7dc86d
+ HASH:=f3c9e574de7073014ab6eef9a0f6412c53ae521b67723360af753c41401ed4d5
endef
PKG_EXTRA_KCONFIG:= \
diff --git a/package/kernel/ar7-atm/Makefile b/package/kernel/ar7-atm/Makefile
index 12ea031bbb..edec44f969 100644
--- a/package/kernel/ar7-atm/Makefile
+++ b/package/kernel/ar7-atm/Makefile
@@ -12,21 +12,21 @@ PKG_NAME:=sangam_atm
ifeq ($(CONFIG_AR7_ATM_FW_VERSION_705),y)
PKG_VERSION:=D7.05.01.00
-PKG_MD5SUM:=42ee465be5cfbe9476fc25deb260d450
+PKG_HASH:=874b5baff92159e99cef0dfb839d6fdc124a46aef7374653064d29d9eee9a3c9
PKG_RELEASE:=R1
PATCH_DIR:=patches-$(PKG_VERSION)
endif
ifeq ($(CONFIG_AR7_ATM_FW_VERSION_704),y)
PKG_VERSION:=D7.04.03.00
-PKG_MD5SUM:=3d76004e46f09e88931f91670cb420ad
+PKG_HASH:=af2e203e4c86f9a86cdd07d172897b07e66a25379376e8da4c1b14816f86b58f
PKG_RELEASE:=R1
PATCH_DIR:=patches-$(PKG_VERSION)
endif
ifeq ($(CONFIG_AR7_ATM_FW_VERSION_703),y)
PKG_VERSION:=D7.03.01.00
-PKG_MD5SUM:=bc6e9c6adb1be25820c7ee661de8ca7d
+PKG_HASH:=2d156164ef5abbe10ffb2400ada4cef2035df3ba2b3f866f00bdede489861c4d
PKG_RELEASE:=R2
PATCH_DIR:=patches-D7.04.03.00
endif
diff --git a/package/kernel/ath10k-ct/Makefile b/package/kernel/ath10k-ct/Makefile
index 041157ecde..bc93344c65 100644
--- a/package/kernel/ath10k-ct/Makefile
+++ b/package/kernel/ath10k-ct/Makefile
@@ -12,6 +12,7 @@ PKG_SOURCE_PROTO:=git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=76533a62824bddfc829ec6ec7cc2a26e9db3d3a2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
+PKG_MIRROR_HASH:=1014d6f94343668934cfbae10d2315406886075b35e8b71421260a197edaf024
PKG_MAINTAINER:=Ben Greear <greearb@candelatech.com>
PKG_BUILD_PARALLEL:=1
diff --git a/package/kernel/brcm2708-gpu-fw/Makefile b/package/kernel/brcm2708-gpu-fw/Makefile
index 093f42d318..d557d232d7 100644
--- a/package/kernel/brcm2708-gpu-fw/Makefile
+++ b/package/kernel/brcm2708-gpu-fw/Makefile
@@ -25,7 +25,7 @@ define Download/LICENCE_broadcom
FILE:=$(RPI_FIRMWARE_FILE)-LICENCE.broadcom
URL:=$(RPI_FIRMWARE_URL)
URL_FILE:=LICENCE.broadcom
- MD5SUM:=ba76edfc10a248166d965b8eaf320771c44f4f432d4fce2fd31fd272e7038add
+ HASH:=ba76edfc10a248166d965b8eaf320771c44f4f432d4fce2fd31fd272e7038add
endef
$(eval $(call Download,LICENCE_broadcom))
@@ -33,7 +33,7 @@ define Download/bootcode_bin
FILE:=$(RPI_FIRMWARE_FILE)-bootcode.bin
URL:=$(RPI_FIRMWARE_URL)
URL_FILE:=bootcode.bin
- MD5SUM:=a11bd31647c25712648757be75a19fa78c1df6f2409c7bf9bd202903f0421c0c
+ HASH:=a11bd31647c25712648757be75a19fa78c1df6f2409c7bf9bd202903f0421c0c
endef
$(eval $(call Download,bootcode_bin))
@@ -41,7 +41,7 @@ define Download/fixup_dat
FILE:=$(RPI_FIRMWARE_FILE)-fixup.dat
URL:=$(RPI_FIRMWARE_URL)
URL_FILE:=fixup.dat
- MD5SUM:=93314d9e01fb53bdf4a25422de89d103cd2e779bd5e81663c658eaecd0c8018e
+ HASH:=93314d9e01fb53bdf4a25422de89d103cd2e779bd5e81663c658eaecd0c8018e
endef
$(eval $(call Download,fixup_dat))
@@ -49,7 +49,7 @@ define Download/fixup_cd_dat
FILE:=$(RPI_FIRMWARE_FILE)-fixup_cd.dat
URL:=$(RPI_FIRMWARE_URL)
URL_FILE:=fixup_cd.dat
- MD5SUM:=638671b81590bfdda5eac683d2025e50bb71c663e702f047ef299e23722f6cdd
+ HASH:=638671b81590bfdda5eac683d2025e50bb71c663e702f047ef299e23722f6cdd
endef
$(eval $(call Download,fixup_cd_dat))
@@ -57,7 +57,7 @@ define Download/start_elf
FILE:=$(RPI_FIRMWARE_FILE)-start.elf
URL:=$(RPI_FIRMWARE_URL)
URL_FILE:=start.elf
- MD5SUM:=cd60fdce9022fa1195a27f3fdf8eba9136476649006e33b72cbdb23dc3b74e90
+ HASH:=cd60fdce9022fa1195a27f3fdf8eba9136476649006e33b72cbdb23dc3b74e90
endef
$(eval $(call Download,start_elf))
@@ -65,7 +65,7 @@ define Download/start_cd_elf
FILE:=$(RPI_FIRMWARE_FILE)-start_cd.elf
URL:=$(RPI_FIRMWARE_URL)
URL_FILE:=start_cd.elf
- MD5SUM:=2f0cdcdaad7b9bf64f5288e206d54e007597c0c4068a5b893c02e0f4c0785ca5
+ HASH:=2f0cdcdaad7b9bf64f5288e206d54e007597c0c4068a5b893c02e0f4c0785ca5
endef
$(eval $(call Download,start_cd_elf))
diff --git a/package/kernel/broadcom-wl/Makefile b/package/kernel/broadcom-wl/Makefile
index 78cbdf0590..2f3a0c5dc1 100644
--- a/package/kernel/broadcom-wl/Makefile
+++ b/package/kernel/broadcom-wl/Makefile
@@ -15,9 +15,12 @@ PKG_RELEASE:=8
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)_$(ARCH).tar.bz2
PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
-PKG_MD5SUM.mipsel:=3363e3a6b3d9d73c49dea870c7834eac
-PKG_MD5SUM.mips:=f8de63debc75333d6b4e28193eb051ff
-PKG_MD5SUM:=$(PKG_MD5SUM.$(ARCH))
+ifeq ($(ARCH),mipsel)
+PKG_HASH:=26a8c370f48fc129d0731cfd751c36cae1419b0bc8ca35781126744e60eae009
+endif
+ifeq ($(ARCH),mips)
+PKG_HASH:=ca6a86ca3e3e9c85b6dbb665b35bcbf338c37829c1b2f1994487d55664886045
+endif
PKG_USE_MIPS16:=0
PKG_FLAGS:=nonshared
diff --git a/package/kernel/ep80579-drivers/Makefile b/package/kernel/ep80579-drivers/Makefile
index 61d3bc2a1f..444157ef3b 100644
--- a/package/kernel/ep80579-drivers/Makefile
+++ b/package/kernel/ep80579-drivers/Makefile
@@ -14,7 +14,7 @@ PKG_RELEASE:=1
PKG_SOURCE:=Embedded.L.1.0.34.ADI.R100.tar.gz
PKG_SOURCE_URL:=ftp://ftp.adiengineering.com/Archive/OcracokeIsland/Drivers/Linux/1.0.34/
-PKG_MD5SUM:=61df9778f8c1f919257d2f48a0bcb000
+PKG_HASH:=f00684176a3dd1dc9ea8d96ecd1ecade5103f351ed93b9e3a5ff5f3f3295e2a9
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
diff --git a/package/kernel/kmod-sched-cake/Makefile b/package/kernel/kmod-sched-cake/Makefile
index 5fdf6878fd..f2e2b85057 100644
--- a/package/kernel/kmod-sched-cake/Makefile
+++ b/package/kernel/kmod-sched-cake/Makefile
@@ -17,7 +17,7 @@ PKG_SOURCE_PROTO:=git
PKG_SOURCE_URL:=https://github.com/kdarbyshirebryant/sch_cake.git
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_MIRROR_MD5SUM:=a7e12c301749a65301d6f452e48207839482b35f5458a693327e5896250ee7dd
+PKG_MIRROR_HASH:=a7e12c301749a65301d6f452e48207839482b35f5458a693327e5896250ee7dd
PKG_MAINTAINER:=Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
include $(INCLUDE_DIR)/package.mk
diff --git a/package/kernel/lantiq/ltq-adsl-fw/Makefile b/package/kernel/lantiq/ltq-adsl-fw/Makefile
index aad8cbd302..5775d0cf50 100644
--- a/package/kernel/lantiq/ltq-adsl-fw/Makefile
+++ b/package/kernel/lantiq/ltq-adsl-fw/Makefile
@@ -14,7 +14,7 @@ PKG_RELEASE:=1
PKG_BUILD_DIR:=$(BUILD_DIR)/ltq-dsl-fw-$(PKG_VERSION)
PKG_SOURCE:=ltq-dsl-fw-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
-PKG_MD5SUM:=4700a36b66b955b4c5544227267356f4
+PKG_HASH:=28676d41c4b76e5bf7a2c5eae106a61fb96b93eabc0cb71120575fff9997269f
PKG_MAINTAINER:=John Crispin <john@phrozen.org>
PKG_FLAGS:=nonshared
diff --git a/package/kernel/lantiq/ltq-adsl/Makefile b/package/kernel/lantiq/ltq-adsl/Makefile
index 19c19a1121..b6f1c8a96a 100644
--- a/package/kernel/lantiq/ltq-adsl/Makefile
+++ b/package/kernel/lantiq/ltq-adsl/Makefile
@@ -14,7 +14,7 @@ PKG_RELEASE:=1
PKG_SOURCE:=drv_dsl_cpe_api_danube-$(PKG_VERSION).tar.gz
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/ltq-dsl-$(BUILD_VARIANT)/drv_dsl_cpe_api-$(PKG_VERSION)
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources/
-PKG_MD5SUM:=c45bc531c1ed2ac80f68fb986b63bb87
+PKG_HASH:=eb2ed59715d3bf4e8a1460bbbe2f1660039e0a9f9d72afb1b2b16590094eb33c
PKG_MAINTAINER:=John Crispin <john@phrozen.org>
PKG_USE_MIPS16:=0
diff --git a/package/kernel/lantiq/ltq-ifxos/Makefile b/package/kernel/lantiq/ltq-ifxos/Makefile
index 7d3f33a984..887136a81a 100644
--- a/package/kernel/lantiq/ltq-ifxos/Makefile
+++ b/package/kernel/lantiq/ltq-ifxos/Makefile
@@ -12,7 +12,7 @@ PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=https://github.com/xdarklight/$(PKG_NAME)/archive/v$(PKG_VERSION)
-PKG_MD5SUM:=39eace039ae4c3dde4da96bfdbee2721
+PKG_HASH:=ed7fe39311d7a4a13d23ed0ae2445c0d825b472b5a98da9b72bcaabcf5ed2d5f
PKG_MAINTAINER:=John Crispin <john@phrozen.org>
PKG_USE_MIPS16:=0
diff --git a/package/kernel/lantiq/ltq-tapi/Makefile b/package/kernel/lantiq/ltq-tapi/Makefile
index a0f19b8b98..be7fd2aa0a 100644
--- a/package/kernel/lantiq/ltq-tapi/Makefile
+++ b/package/kernel/lantiq/ltq-tapi/Makefile
@@ -14,7 +14,7 @@ PKG_RELEASE:=3
PKG_SOURCE:=drv_tapi-$(PKG_VERSION).tar.bz2
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
-PKG_MD5SUM:=edb43b494832c540cc035493d18db58f
+PKG_HASH:=109374d52872716570fca3fef3b93c9a93159a804dfd42484b19152b825af5c0
PKG_MAINTAINER:=John Crispin <john@phrozen.org>
PKG_USE_MIPS16:=0
diff --git a/package/kernel/lantiq/ltq-vdsl-mei/Makefile b/package/kernel/lantiq/ltq-vdsl-mei/Makefile
index a4d6e3504a..c6830ca3a1 100644
--- a/package/kernel/lantiq/ltq-vdsl-mei/Makefile
+++ b/package/kernel/lantiq/ltq-vdsl-mei/Makefile
@@ -15,7 +15,7 @@ PKG_BASE_NAME:=drv_mei_cpe
PKG_SOURCE:=$(PKG_BASE_NAME)-$(PKG_VERSION).tar.gz
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_BASE_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
-PKG_MD5SUM:=05179cec47b51dbb66024e8a993b6e0a
+PKG_HASH:=94f6904364348b7f74087e721968abc28b2564fb9bd8899aa930d36490387662
PKG_FIXUP:=autoreconf
PKG_FLAGS:=nonshared
PKG_MAINTAINER:=John Crispin <john@phrozen.org>
diff --git a/package/kernel/lantiq/ltq-vdsl/Makefile b/package/kernel/lantiq/ltq-vdsl/Makefile
index 7e891d6f4c..c9667c9945 100644
--- a/package/kernel/lantiq/ltq-vdsl/Makefile
+++ b/package/kernel/lantiq/ltq-vdsl/Makefile
@@ -15,7 +15,7 @@ PKG_BASE_NAME:=drv_dsl_cpe_api
PKG_SOURCE:=$(PKG_BASE_NAME)_vrx-$(PKG_VERSION).tar.gz
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_BASE_NAME)-$(PKG_VERSION)
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
-PKG_MD5SUM:=72bb0218a7cbd2ea860bff4acc1c511e
+PKG_HASH:=b4966a60653acc49254b168c6cc9c49eb36c54548e763617788aa4f252a29f21
PKG_USE_MIPS16:=0
diff --git a/package/kernel/lantiq/ltq-vmmc/Makefile b/package/kernel/lantiq/ltq-vmmc/Makefile
index b51e0dfcf2..ab0ef727b3 100644
--- a/package/kernel/lantiq/ltq-vmmc/Makefile
+++ b/package/kernel/lantiq/ltq-vmmc/Makefile
@@ -13,7 +13,7 @@ PKG_VERSION:=1.9.0
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
-PKG_MD5SUM:=d8eee8cba0edb28974cc1f8532e3bd18
+PKG_HASH:=707f515eb727c032418c4da67d7e86884bb56cdc2a606e8f6ded6057d8767e57
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
PKG_MAINTAINER:=John Crispin <john@phrozen.org>
@@ -79,12 +79,12 @@ ifeq ($(CONFIG_VOICE_CPE_VMMC_WITH_DEVICE_DANUBE)$(CONFIG_LTQ_VOICE_CPE_VMMC_WIT
FW_SOURCE:=voip_R12.1.0.1.0-enc.bin
FW_TARGET:=danube_firmware.bin
FW_FILE=fw_voip_danube-12.1.0.1.0.tar.gz
- FW_MD5SUM:=51868b88dee9dbc65d3dbba355ded91c
+ FW_HASH:=bb92a6f1b864f217863e435eab6e5bbf8fe9a06b1398fe5aa8542baf53f7d927
FW_DOWNLOAD:=1
COEF_SRC:=danube_bbd_fxs.bin
COEF_TARGET:=danube_bbd_fxs.bin
COEF_FILE:=coef_voip_danube-0.9.0.tar.gz
- COEF_MD5SUM:=c8ac6592b304b03829a8123560e15710
+ COEF_HASH:=6578d6c8f4874b7e4bf10d10c7e5b7e913f6a7cdeba998fb04f28c41f94c82c1
COEF_DOWNLOAD:=1
endif
@@ -98,7 +98,7 @@ COEF_SRC:=$(COEF_TARGET)
ifeq ($(CONFIG_VOICE_VMMC_WITH_DEVICE_FALCON),y)
CONFIGURE_ARGS += --with-device=FALCON
FW_SOURCE:=voip_R1.1.0.6.0-enc.bin
- FW_MD5SUM:=cd4366a52a8010b76793e3810a4f14b3
+ FW_HASH:=5046a9df736ce302bb240f262c2557c4c9d9b214c22ea67910e3a01a3728c84a
FW_TARGET:=falcon_voip_fw.bin
FW_FILE=fw_voip_falcon-1.1.0.6.0.tar.gz
FW_DOWNLOAD:=1
@@ -114,7 +114,7 @@ ifeq ($(CONFIG_LTQ_VOICE_CPE_VMMC_COEF_FALCON_USE_CUSTOM_FILE),y)
COEF_SRC:=$(CONFIG_LTQ_VOICE_CPE_VMMC_COEF_FALCON_CUSTOM_FILE)
endif
COEF_FILE:=coef_voip_falcon.tar.gz
- COEF_MD5SUM:=56c5a838f2bb9bd87d0e8dce271f810b
+ COEF_HASH:=9b63b2cc7fefdad36d43c307227fc1aade3cf5600ee75fb572da6d908238cf60
COEF_DOWNLOAD:=1
endif
@@ -123,12 +123,12 @@ ifeq ($(CONFIG_VOICE_CPE_VMMC_WITH_DEVICE_VR9),y)
FW_TARGET:=voice_ar9_firmware.bin
FW_SOURCE:=voip_R2.3.1.7.0-enc.bin
FW_FILE=fw_voip_vr9-2.3.1.7.0.tar.gz
- FW_MD5SUM:=9d716b99349b56b619dbaf6647b227cb
+ FW_HASH:=bc64da5a44a5440d6008f80a5d3f6fdb15c90f9b4023795d1b5b8e35c50bd167
FW_DOWNLOAD:=1
COEF_SRC:=ETSI_3_10.BIN
COEF_TARGET:=vr9_bbd_fxs.bin
COEF_FILE:=coef_voip_vr9-0.9.3.tar.gz
- COEF_MD5SUM:=66fa5c6a4110726b1f8658359b8008e6
+ COEF_HASH:=3264ed2ab0316bdda419b649fd0d6cadf02540c7e5dc0ea501a7fb680fb371e7
COEF_DOWNLOAD:=1
COEF_SRC_FXO:=FXO_ETSI_0_0.BIN
@@ -138,14 +138,14 @@ endif
define Download/firmware
FILE:=$(FW_FILE)
URL:=$(FW_URL)
- MD5SUM:=$(FW_MD5SUM)
+ HASH:=$(FW_HASH)
endef
$(eval $(if $(FW_DOWNLOAD),$(call Download,firmware)))
define Download/coef
FILE:=$(COEF_FILE)
URL:=$(FW_URL)
- MD5SUM:=$(COEF_MD5SUM)
+ HASH:=$(COEF_HASH)
endef
$(eval $(if $(COEF_DOWNLOAD),$(call Download,coef)))
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 93a91b1ab8..99aa1fc3be 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -14,7 +14,7 @@ PKG_VERSION:=2016-10-08
PKG_RELEASE:=1
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
PKG_BACKPORT_VERSION:=
-PKG_MD5SUM:=4f6350e3b75815060bfdf47ef266ad613c7bfea5b7b1dc4552dee69e1bebe4fb
+PKG_HASH:=4f6350e3b75815060bfdf47ef266ad613c7bfea5b7b1dc4552dee69e1bebe4fb
PKG_SOURCE:=compat-wireless-$(PKG_VERSION)$(PKG_BACKPORT_VERSION).tar.bz2
PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/compat-wireless-$(PKG_VERSION)
@@ -297,7 +297,7 @@ ifneq ($(CONFIG_B43_FW_6_30),)
PKG_B43_FWV4_OBJECT:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION).wl_apsta.o
PKG_B43_FWV4_SOURCE:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION).tar.bz2
PKG_B43_FWV4_SOURCE_URL:=http://www.lwfinger.com/b43-firmware/
- PKG_B43_FWV4_MD5SUM:=6fe97e9368d25342a1ab943d3cf3496d
+ PKG_B43_FWV4_HASH:=a07c3b6b277833c7dbe61daa511f908cd66c5e2763eb7a0859abc36cd9335c2d
else
ifneq ($(CONFIG_B43_FW_5_10),)
PKG_B43_FWV4_NAME:=broadcom-wl
@@ -305,7 +305,7 @@ ifneq ($(CONFIG_B43_FW_5_10),)
PKG_B43_FWV4_OBJECT:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION)/driver/wl_apsta/wl_prebuilt.o
PKG_B43_FWV4_SOURCE:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION)_mipsel.tar.bz2
PKG_B43_FWV4_SOURCE_URL:=http://mirror2.openwrt.org/sources/
- PKG_B43_FWV4_MD5SUM:=3363e3a6b3d9d73c49dea870c7834eac
+ PKG_B43_FWV4_HASH:=26a8c370f48fc129d0731cfd751c36cae1419b0bc8ca35781126744e60eae009
else
ifneq ($(CONFIG_B43_FW_4_178),)
PKG_B43_FWV4_NAME:=broadcom-wl
@@ -313,7 +313,7 @@ ifneq ($(CONFIG_B43_FW_4_178),)
PKG_B43_FWV4_OBJECT:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION)/linux/wl_apsta.o
PKG_B43_FWV4_SOURCE:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION).tar.bz2
PKG_B43_FWV4_SOURCE_URL:=http://mirror2.openwrt.org/sources/
- PKG_B43_FWV4_MD5SUM:=14477e8cbbb91b11896affac9b219fdb
+ PKG_B43_FWV4_HASH:=32f6ad98facbb9045646fdc8b54bb03086d204153253f9c65d0234a5d90ae53f
else
ifneq ($(CONFIG_B43_FW_5_100_138),)
PKG_B43_FWV4_NAME:=broadcom-wl
@@ -321,14 +321,14 @@ ifneq ($(CONFIG_B43_FW_5_100_138),)
PKG_B43_FWV4_OBJECT:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION)/linux/wl_apsta.o
PKG_B43_FWV4_SOURCE:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION).tar.bz2
PKG_B43_FWV4_SOURCE_URL:=http://www.lwfinger.com/b43-firmware/
- PKG_B43_FWV4_MD5SUM:=f4e357b09eaf5d8b1f1920cf3493a555
+ PKG_B43_FWV4_HASH:=f1e7067aac5b62b67b8b6e4c517990277804339ac16065eb13c731ff909ae46f
else
PKG_B43_FWV4_NAME:=broadcom-wl
PKG_B43_FWV4_VERSION:=4.150.10.5
PKG_B43_FWV4_OBJECT:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION)/driver/wl_apsta_mimo.o
PKG_B43_FWV4_SOURCE:=$(PKG_B43_FWV4_NAME)-$(PKG_B43_FWV4_VERSION).tar.bz2
PKG_B43_FWV4_SOURCE_URL:=http://mirror2.openwrt.org/sources/
- PKG_B43_FWV4_MD5SUM:=0c6ba9687114c6b598e8019e262d9a60
+ PKG_B43_FWV4_HASH:=a9f4e276a4d8d3a1cd0f2eb87080ae89b77f0a7140f06d4e9e2135fc44fdd533
endif
endif
endif
@@ -338,15 +338,15 @@ ifneq ($(CONFIG_B43_OPENFIRMWARE),)
PKG_B43_FWV4_VERSION:=5.2
PKG_B43_FWV4_OBJECT:=openfwwf-$(PKG_B43_FWV4_VERSION)
PKG_B43_FWV4_SOURCE:=openfwwf-$(PKG_B43_FWV4_VERSION).tar.gz
- PKG_B43_FWV4_SOURCE_URL:=http://www.ing.unibs.it/openfwwf/firmware/
- PKG_B43_FWV4_MD5SUM:=e045a135453274e439ae183f8498b0fa
+ PKG_B43_FWV4_SOURCE_URL:=http://netweb.ing.unibs.it/~openfwwf/firmware
+ PKG_B43_FWV4_HASH:=9de03320083201080b2e94b81637ac07a159cf4e6f3481383e1a217e627bc0dc
endif
define Download/b43
FILE:=$(PKG_B43_FWV4_SOURCE)
URL:=$(PKG_B43_FWV4_SOURCE_URL)
- MD5SUM:=$(PKG_B43_FWV4_MD5SUM)
+ HASH:=$(PKG_B43_FWV4_HASH)
endef
$(eval $(call Download,b43))
@@ -641,12 +641,12 @@ PKG_BRCMSMAC_FW_VERSION:=5.100.138
PKG_BRCMSMAC_FW_OBJECT:=$(PKG_BRCMSMAC_FW_NAME)-$(PKG_BRCMSMAC_FW_VERSION)/linux/wl_apsta.o
PKG_BRCMSMAC_FW_SOURCE:=$(PKG_BRCMSMAC_FW_NAME)-$(PKG_BRCMSMAC_FW_VERSION).tar.bz2
PKG_BRCMSMAC_FW_SOURCE_URL:=http://www.lwfinger.com/b43-firmware/
-PKG_BRCMSMAC_FW_MD5SUM:=f4e357b09eaf5d8b1f1920cf3493a555
+PKG_BRCMSMAC_FW_HASH:=f1e7067aac5b62b67b8b6e4c517990277804339ac16065eb13c731ff909ae46f
define Download/brcmsmac
FILE:=$(PKG_BRCMSMAC_FW_SOURCE)
URL:=$(PKG_BRCMSMAC_FW_SOURCE_URL)
- MD5SUM:=$(PKG_BRCMSMAC_FW_MD5SUM)
+ HASH:=$(PKG_BRCMSMAC_FW_HASH)
endef
$(eval $(call Download,brcmsmac))
@@ -942,7 +942,7 @@ IPW2100_VERSION:=1.3
define Download/ipw2100
URL:=http://bughost.org/firmware/
FILE:=$(IPW2100_NAME)-$(IPW2100_VERSION).tgz
- MD5SUM=46aa75bcda1a00efa841f9707bbbd113
+ HASH:=e1107c455e48d324a616b47a622593bc8413dcce72026f72731c0b03dae3a7a2
endef
$(eval $(call Download,ipw2100))
@@ -966,7 +966,7 @@ IPW2200_VERSION:=3.1
define Download/ipw2200
URL:=http://bughost.org/firmware/
FILE:=$(IPW2200_NAME)-$(IPW2200_VERSION).tgz
- MD5SUM=eaba788643c7cc7483dd67ace70f6e99
+ HASH:=c6818c11c18cc030d55ff83f64b2bad8feef485e7742f84f94a61d811a6258bd
endef
$(eval $(call Download,ipw2200))
@@ -1426,7 +1426,7 @@ ZD1211FW_VERSION:=1.4
define Download/zd1211rw
FILE:=$(ZD1211FW_NAME)-$(ZD1211FW_VERSION).tar.bz2
URL:=@SF/zd1211/
- MD5SUM:=19f28781d76569af8551c9d11294c870
+ HASH:=866308f6f59f7075f075d4959dff2ede47735c751251fecd1496df1ba4d338e1
endef
$(eval $(call Download,zd1211rw))
diff --git a/package/kernel/mt76/Makefile b/package/kernel/mt76/Makefile
index c14b831827..e756deea3f 100644
--- a/package/kernel/mt76/Makefile
+++ b/package/kernel/mt76/Makefile
@@ -12,6 +12,7 @@ PKG_SOURCE_PROTO:=git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=7ce4368c3d508b61993466fa5a13a3b5929bde4b
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
+PKG_MIRROR_HASH:=26430cf25de1baa41ef0e2508a8d5438f82f2a3b7448905ada23280d8f9c7f6c
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_BUILD_PARALLEL:=1
diff --git a/package/kernel/mwlwifi/Makefile b/package/kernel/mwlwifi/Makefile
index fa65b6f30d..2349e72036 100644
--- a/package/kernel/mwlwifi/Makefile
+++ b/package/kernel/mwlwifi/Makefile
@@ -19,6 +19,7 @@ PKG_SOURCE_PROTO:=git
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
PKG_SOURCE_VERSION:=41db55d3872cad94763a5fa0c5f028fa1ab66f58
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.xz
+PKG_MIRROR_HASH:=0ffe533c04c8b1a834a220fb67f9db3b291e160fd3aa1e92d1e36df0ed2afa64
PKG_MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
PKG_BUILD_PARALLEL:=1