aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@openwrt.org>2012-01-18 17:13:23 +0000
committerHauke Mehrtens <hauke@openwrt.org>2012-01-18 17:13:23 +0000
commit6ef002c501c3175612c4af757b72265604fae522 (patch)
tree38d442d92a7063505597b8a3ca88c3f2e44c48f7 /package/kernel
parentbaafb55f70c8f354c76ae7f6e7cf88cd1a489d88 (diff)
downloadupstream-6ef002c501c3175612c4af757b72265604fae522.tar.gz
upstream-6ef002c501c3175612c4af757b72265604fae522.tar.bz2
upstream-6ef002c501c3175612c4af757b72265604fae522.zip
packages: kernel: add usb-common.ko to usb package for kernel >= 3.2
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@29776 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/usb.mk11
1 files changed, 9 insertions, 2 deletions
diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index fd027bca61..d92f9ce032 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -16,8 +16,15 @@ define KernelPackage/usb-core
TITLE:=Support for USB
DEPENDS:=@USB_SUPPORT
KCONFIG:=CONFIG_USB CONFIG_XPS_USB_HCD_XILINX=n CONFIG_USB_FHCI_HCD=n
- FILES:=$(LINUX_DIR)/drivers/usb/core/usbcore.ko
- AUTOLOAD:=$(call AutoLoad,20,usbcore,1)
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.2)),1)
+ FILES:= \
+ $(LINUX_DIR)/drivers/usb/core/usbcore.ko \
+ $(LINUX_DIR)/drivers/usb/usb-common.ko
+ AUTOLOAD:=$(call AutoLoad,20,usb-common usbcore,1)
+ else
+ FILES:=$(LINUX_DIR)/drivers/usb/core/usbcore.ko
+ AUTOLOAD:=$(call AutoLoad,20,usbcore,1)
+ endif
$(call AddDepends/nls)
endef