aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-04-25 13:43:15 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-04-25 13:43:15 +0000
commit68a6a13517532f16727755664818734ebcf1ffb9 (patch)
tree20bc13b0dfa0fb64a246b2e0bb1f9a1d14d52ce8 /package/kernel
parenta447f1810c0e3d74e8eeaf0b6eea8b712f026338 (diff)
downloadupstream-68a6a13517532f16727755664818734ebcf1ffb9.tar.gz
upstream-68a6a13517532f16727755664818734ebcf1ffb9.tar.bz2
upstream-68a6a13517532f16727755664818734ebcf1ffb9.zip
kernel: fix packaging of 8250.ko with Linux 3.x This commit fixes build breakage in package/kernel leading to missing subsequent kmods like kmod-usb-serial, this should fix the missing packages in ar71xx builds.
SVN-Revision: 31477
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk8
1 files changed, 8 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index abac4811d4..d3450cf73b 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -896,7 +896,15 @@ define KernelPackage/serial-8250
CONFIG_SERIAL_8250_SHARE_IRQ=y \
CONFIG_SERIAL_8250_DETECT_IRQ=n \
CONFIG_SERIAL_8250_RSA=n
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.3)),1)
+ FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/8250.ko
+else
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.38)),1)
FILES:=$(LINUX_DIR)/drivers/tty/serial/8250.ko
+ else
+ FILES:=$(LINUX_DIR)/drivers/serial/8250.ko
+ endif
+endif
endef
define KernelPackage/serial-8250/description