aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2011-05-25 19:51:40 +0000
committerHauke Mehrtens <hauke@hauke-m.de>2011-05-25 19:51:40 +0000
commit6769216a6490f7422294d3b5ae679403156ffbb5 (patch)
tree8f901ccb198669d2f29fc5826c6da9d5e4b9874b /package/kernel
parentc69f2d8788919032dd1046983eb820198571bc97 (diff)
downloadupstream-6769216a6490f7422294d3b5ae679403156ffbb5.tar.gz
upstream-6769216a6490f7422294d3b5ae679403156ffbb5.tar.bz2
upstream-6769216a6490f7422294d3b5ae679403156ffbb5.zip
kernel: generic: Update 2.6.39 to final
* Add missing config symbols * Update package/kernel for 2.6.39 CONFIG_BT_L2CAP=y and CONFIG_BT_SCO=y are set to build them into the bluetooth module. Thank you Jonas Gorski for the patch SVN-Revision: 27010
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/netsupport.mk8
-rw-r--r--package/kernel/modules/other.mk11
-rw-r--r--package/kernel/modules/usb.mk4
-rw-r--r--package/kernel/modules/virtual.mk2
4 files changed, 15 insertions, 10 deletions
diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index a1518156fa..7387319731 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -477,7 +477,7 @@ $(eval $(call KernelPackage,pppoa))
define KernelPackage/pptp
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=PPtP support
- DEPENDS:=kmod-ppp +kmod-gre @LINUX_2_6_37||LINUX_2_6_38
+ DEPENDS:=kmod-ppp +kmod-gre @LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39
KCONFIG:=CONFIG_PPTP
FILES:=$(LINUX_DIR)/drivers/net/pptp.ko
AUTOLOAD:=$(call AutoLoad,41,pptp)
@@ -489,9 +489,9 @@ $(eval $(call KernelPackage,pptp))
define KernelPackage/pppol2tp
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=PPPoL2TP support
- DEPENDS:=kmod-ppp +kmod-pppoe +LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38:kmod-l2tp
+ DEPENDS:=kmod-ppp +kmod-pppoe +LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39:kmod-l2tp
KCONFIG:=CONFIG_PPPOL2TP
- ifneq ($(CONFIG_LINUX_2_6_35)$(CONFIG_LINUX_2_6_36)$(CONFIG_LINUX_2_6_37)$(CONFIG_LINUX_2_6_38),)
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.35)),1)
FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ppp.ko
AUTOLOAD:=$(call AutoLoad,40,l2tp_ppp)
else
@@ -652,7 +652,7 @@ $(eval $(call KernelPackage,pktgen))
define KernelPackage/l2tp
SUBMENU:=$(NETWORK_SUPPORT_MENU)
- DEPENDS:=@LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38
+ DEPENDS:=@LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39
TITLE:=Layer Two Tunneling Protocol (L2TP)
KCONFIG:=CONFIG_L2TP \
CONFIG_L2TP_V3=y \
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 5ab43368ee..3e17dc345d 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -38,14 +38,19 @@ define KernelPackage/bluetooth
$(call AddDepends/rfkill)
FILES:= \
$(LINUX_DIR)/net/bluetooth/bluetooth.ko \
- $(LINUX_DIR)/net/bluetooth/l2cap.ko \
- $(LINUX_DIR)/net/bluetooth/sco.ko \
$(LINUX_DIR)/net/bluetooth/rfcomm/rfcomm.ko \
$(LINUX_DIR)/net/bluetooth/bnep/bnep.ko \
$(LINUX_DIR)/net/bluetooth/hidp/hidp.ko \
$(LINUX_DIR)/drivers/bluetooth/hci_uart.ko \
$(LINUX_DIR)/drivers/bluetooth/btusb.ko
- AUTOLOAD:=$(call AutoLoad,90,bluetooth l2cap sco rfcomm bnep hidp hci_uart btusb)
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.39)),1)
+ AUTOLOAD:=$(call AutoLoad,90,bluetooth rfcomm bnep hidp hci_uart btusb)
+ else
+ FILES+= \
+ $(LINUX_DIR)/net/bluetooth/l2cap.ko \
+ $(LINUX_DIR)/net/bluetooth/sco.ko
+ AUTOLOAD:=$(call AutoLoad,90,bluetooth l2cap sco rfcomm bnep hidp hci_uart btusb)
+ endif
endef
define KernelPackage/bluetooth/description
diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index e543cd644e..587bb8daa4 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -546,7 +546,7 @@ $(eval $(call KernelPackage,usb-serial-keyspan))
define KernelPackage/usb-serial-wwan
TITLE:=Support for GSM and CDMA modems
- DEPENDS:= @LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38
+ DEPENDS:= @LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39
KCONFIG:=CONFIG_USB_SERIAL_WWAN
FILES:=$(LINUX_DIR)/drivers/usb/serial/usb_wwan.ko
AUTOLOAD:=$(call AutoLoad,61,usb_wwan)
@@ -562,7 +562,7 @@ $(eval $(call KernelPackage,usb-serial-wwan))
define KernelPackage/usb-serial-option
TITLE:=Support for Option HSDPA modems
- DEPENDS:=+LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38:kmod-usb-serial-wwan
+ DEPENDS:=+LINUX_2_6_35||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39:kmod-usb-serial-wwan
KCONFIG:=CONFIG_USB_SERIAL_OPTION
FILES:=$(LINUX_DIR)/drivers/usb/serial/option.ko
AUTOLOAD:=$(call AutoLoad,65,option)
diff --git a/package/kernel/modules/virtual.mk b/package/kernel/modules/virtual.mk
index 8f9261acdb..3e243585b8 100644
--- a/package/kernel/modules/virtual.mk
+++ b/package/kernel/modules/virtual.mk
@@ -166,7 +166,7 @@ $(eval $(call KernelPackage,xen-netdev))
define KernelPackage/xen-pcidev
SUBMENU:=$(VIRTUAL_MENU)
TITLE:=Xen PCI device frontend
- DEPENDS:=@TARGET_x86_xen_domu @LINUX_2_6_37||LINUX_2_6_38
+ DEPENDS:=@TARGET_x86_xen_domu @LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39
KCONFIG:=CONFIG_XEN_PCIDEV_FRONTEND
FILES:=$(LINUX_DIR)/drivers/xen/platform-pci.ko
AUTOLOAD:=$(call AutoLoad,10,xen-pcifront)