aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorAleksander Jan Bajkowski <A.Bajkowski@stud.elka.pw.edu.pl>2021-05-02 11:27:23 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-05-23 15:11:38 +0200
commit577ba5a3a952d3b278fda11cefba641ba778f06d (patch)
treef01f366433f38b71b90bcc1cfc996c00860f9daf /package/kernel
parentf298d5b810118c02b340c5bb5c85e1ac11579677 (diff)
downloadupstream-577ba5a3a952d3b278fda11cefba641ba778f06d.tar.gz
upstream-577ba5a3a952d3b278fda11cefba641ba778f06d.tar.bz2
upstream-577ba5a3a952d3b278fda11cefba641ba778f06d.zip
kernel: crypto: drop kmod-crypto-pcompress
CONFIG_CRYPTO_PCOMP and CONFIG_CRYPTO_PCOMP2 have been removed in upstream commit[1]. This symbol doesn't exist since kernel 4.6 and this package is empty. 1. [ crypto: compress - remove unused pcomp interface ] (https://github.com/torvalds/linux/commit/110492183c4b8f572b16fce096b9d78e2da30baf) Signed-off-by: Aleksander Jan Bajkowski <A.Bajkowski@stud.elka.pw.edu.pl>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/crypto.mk15
1 files changed, 1 insertions, 14 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index edce712c56..f07676d6b7 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -600,7 +600,7 @@ $(eval $(call KernelPackage,crypto-lib-poly1305))
define KernelPackage/crypto-manager
TITLE:=CryptoAPI algorithm manager
- DEPENDS:=+kmod-crypto-aead +kmod-crypto-hash +kmod-crypto-pcompress
+ DEPENDS:=+kmod-crypto-aead +kmod-crypto-hash
KCONFIG:= \
CONFIG_CRYPTO_MANAGER \
CONFIG_CRYPTO_MANAGER2
@@ -770,19 +770,6 @@ endef
$(eval $(call KernelPackage,crypto-pcbc))
-define KernelPackage/crypto-pcompress
- TITLE:=CryptoAPI Partial (de)compression operations
- KCONFIG:= \
- CONFIG_CRYPTO_PCOMP=y \
- CONFIG_CRYPTO_PCOMP2
- FILES:=$(LINUX_DIR)/crypto/pcompress.ko
- AUTOLOAD:=$(call AutoLoad,09,pcompress)
- $(call AddDepends/crypto)
-endef
-
-$(eval $(call KernelPackage,crypto-pcompress))
-
-
define KernelPackage/crypto-rsa
TITLE:=RSA algorithm
DEPENDS:=+kmod-crypto-manager +kmod-asn1-decoder