aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2017-01-09 17:18:21 -0700
committerJohn Crispin <john@phrozen.org>2017-03-29 08:21:09 +0200
commit513dff3cca9a8f800c63ccda7a4d0a168f48a814 (patch)
tree3ac298938edab780403edd0c5f4b936fb3c8bfca /package/kernel
parent22ee675f0450d42af6c336f0d81e023262dc48ed (diff)
downloadupstream-513dff3cca9a8f800c63ccda7a4d0a168f48a814.tar.gz
upstream-513dff3cca9a8f800c63ccda7a4d0a168f48a814.tar.bz2
upstream-513dff3cca9a8f800c63ccda7a4d0a168f48a814.zip
kernel: add w83627hf-wdt watchdog timer module
This is a 3rd party chipset which is not present on all Intel reference designs, so make it a module rather than baked in (this will also alleviate conflicts with drivers which also detect some of the same chipsets). Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/other.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 8ea435ed84..b8b22411b2 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -1018,3 +1018,18 @@ define KernelPackage/tpm-i2c-infineon/description
endef
$(eval $(call KernelPackage,tpm-i2c-infineon))
+
+
+define KernelPackage/w83627hf-wdt
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=Winbond 83627HF Watchdog Timer
+ KCONFIG:=CONFIG_W83627HF_WDT
+ FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/w83627hf_wdt.ko
+ AUTOLOAD:=$(call AutoLoad,50,w83627hf-wdt,1)
+endef
+
+define KernelPackage/w83627hf-wdt/description
+ Kernel module for Winbond 83627HF Watchdog Timer
+endef
+
+$(eval $(call KernelPackage,w83627hf-wdt))