aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-24 12:29:50 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-24 12:29:50 +0000
commit4d773ec4d1114ecaee84e04fb9fbfc720aeb713f (patch)
treef45158a17fa10b4c745aaea3273178210d182ea3 /package/kernel
parent0655bed93c6f51a715d5fed6389bf2da0604ef55 (diff)
downloadupstream-4d773ec4d1114ecaee84e04fb9fbfc720aeb713f.tar.gz
upstream-4d773ec4d1114ecaee84e04fb9fbfc720aeb713f.tar.bz2
upstream-4d773ec4d1114ecaee84e04fb9fbfc720aeb713f.zip
package/kernel: allow additional dependencies as arguments to AddDepends macros
SVN-Revision: 21128
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/001-depends.mk9
1 files changed, 4 insertions, 5 deletions
diff --git a/package/kernel/modules/001-depends.mk b/package/kernel/modules/001-depends.mk
index 5cb3412081..61d892198e 100644
--- a/package/kernel/modules/001-depends.mk
+++ b/package/kernel/modules/001-depends.mk
@@ -12,7 +12,7 @@ define SetDepends/crc16
endef
define AddDepends/crc16
- DEPENDS+= +!TARGET_xburst:kmod-crc16
+ DEPENDS+= +!TARGET_xburst:kmod-crc16 $(1)
endef
@@ -21,7 +21,7 @@ define SetDepends/hid
endef
define AddDepends/hid
- DEPENDS+= +!TARGET_x86:kmod-hid
+ DEPENDS+= +!TARGET_x86:kmod-hid $(1)
endef
@@ -31,7 +31,7 @@ define SetDepends/input
endef
define AddDepends/input
- DEPENDS+= +!TARGET_x86:kmod-input-core
+ DEPENDS+= +!TARGET_x86:kmod-input-core $(1)
endef
@@ -40,6 +40,5 @@ define SetDepends/rfkill
endef
define AddDepends/rfkill
- DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86):kmod-rfkill
-
+ DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86):kmod-rfkill $(1)
endef