aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2012-03-27 19:37:57 +0000
committerGabor Juhos <juhosg@openwrt.org>2012-03-27 19:37:57 +0000
commit475b212867ee731a1b16f5c40eab2f72f1444605 (patch)
tree105c6af9e7a75b9ed530c2cbd2d0cd3897cb8569 /package/kernel
parentb5219fd99fa5ac8c3ee2a3a3f8068f4c2b60aa62 (diff)
downloadupstream-475b212867ee731a1b16f5c40eab2f72f1444605.tar.gz
upstream-475b212867ee731a1b16f5c40eab2f72f1444605.tar.bz2
upstream-475b212867ee731a1b16f5c40eab2f72f1444605.zip
package/kernel: allow to build RTC modules for 3.x
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@31105 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/001-depends.mk7
-rw-r--r--package/kernel/modules/other.mk25
2 files changed, 26 insertions, 6 deletions
diff --git a/package/kernel/modules/001-depends.mk b/package/kernel/modules/001-depends.mk
index 407f873a5e..a52794b972 100644
--- a/package/kernel/modules/001-depends.mk
+++ b/package/kernel/modules/001-depends.mk
@@ -30,3 +30,10 @@ endef
define AddDepends/rfkill
DEPENDS+= +(TARGET_ar71xx||TARGET_brcm47xx||TARGET_s3c24xx||TARGET_x86):kmod-rfkill $(1)
endef
+
+
+define AddDepends/rtc
+ DEPENDS+= \
+ +(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-rtc-core-2.6 \
+ +!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39):kmod-rtc-core-3.x
+endef
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 69c7a78fcb..bae8fe39ff 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -750,25 +750,38 @@ endef
$(eval $(call KernelPackage,pwm-gpio))
-define KernelPackage/rtc-core
+define KernelPackage/rtc-core-2.6
SUBMENU:=$(OTHER_MENU)
- DEPENDS:=@LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39||BROKEN
+ DEPENDS:=@LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39
TITLE:=Real Time Clock class support
KCONFIG:=CONFIG_RTC_CLASS
FILES:=$(LINUX_DIR)/drivers/rtc/rtc-core.ko
AUTOLOAD:=$(call AutoLoad,29,rtc-core)
endef
-define KernelPackage/rtc-core/description
+define KernelPackage/rtc-core-2.6/description
Generic RTC class support.
endef
-$(eval $(call KernelPackage,rtc-core))
+$(eval $(call KernelPackage,rtc-core-2.6))
+
+define KernelPackage/rtc-core-3.x
+ SUBMENU:=$(OTHER_MENU)
+ DEPENDS:=@!(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39)
+ TITLE:=Real Time Clock class support
+ KCONFIG:=CONFIG_RTC_CLASS=y
+endef
+
+define KernelPackage/rtc-core-3.x/description
+ Generic RTC class support.
+endef
+
+$(eval $(call KernelPackage,rtc-core-3.x))
define KernelPackage/rtc-pcf8563
SUBMENU:=$(OTHER_MENU)
TITLE:=Philips PCF8563/Epson RTC8564 RTC support
- DEPENDS:=+(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39||BROKEN):kmod-rtc-core
+ $(call AddDepends/rtc)
KCONFIG:=CONFIG_RTC_DRV_PCF8563
FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pcf8563.ko
AUTOLOAD:=$(call AutoLoad,60,rtc-pcf8563)
@@ -785,7 +798,7 @@ $(eval $(call KernelPackage,rtc-pcf8563))
define KernelPackage/rtc-pcf2123
SUBMENU:=$(OTHER_MENU)
TITLE:=Philips PCF2123 RTC support
- DEPENDS:=+(LINUX_2_6_30||LINUX_2_6_31||LINUX_2_6_32||LINUX_2_6_36||LINUX_2_6_37||LINUX_2_6_38||LINUX_2_6_39||BROKEN):kmod-rtc-core
+ $(call AddDepends/rtc)
KCONFIG:=CONFIG_RTC_DRV_PCF2123
FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pcf2123.ko
AUTOLOAD:=$(call AutoLoad,60,rtc-pcf2123)