aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2013-01-08 22:18:23 +0000
committerFlorian Fainelli <florian@openwrt.org>2013-01-08 22:18:23 +0000
commit44cf7625b0ff51ffea83b8142e69002aee6fc4eb (patch)
treed396a8471d02b26d5b3d6013f32c9d15c052c82e /package/kernel
parent3720f45e3cf20e62fb57ac3f838d7b28a3e56db5 (diff)
downloadupstream-44cf7625b0ff51ffea83b8142e69002aee6fc4eb.tar.gz
upstream-44cf7625b0ff51ffea83b8142e69002aee6fc4eb.tar.bz2
upstream-44cf7625b0ff51ffea83b8142e69002aee6fc4eb.zip
kernel: add more SCTP related configuration symbols
These symbols are used by 3.8+ kernels Signed-off-by: Florian Fainelli <florian@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@35054 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/netsupport.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index 7858f47749..d893c1add7 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -836,7 +836,12 @@ define KernelPackage/sctp
CONFIG_SCTP_DBG_OBJCNT=n \
CONFIG_SCTP_HMAC_NONE=n \
CONFIG_SCTP_HMAC_SHA1=n \
- CONFIG_SCTP_HMAC_MD5=y
+ CONFIG_SCTP_HMAC_MD5=y \
+ CONFIG_SCTP_COOKIE_HMAC_SHA1=n \
+ CONFIG_SCTP_COOKIE_HMAC_MD5=y \
+ CONFIG_SCTP_DEFAULT_COOKIE_HMAC_NONE=n \
+ CONFIG_SCTP_DEFAULT_COOKIE_HMAC_SHA1=n \
+ CONFIG_SCTP_DEFAULT_COOKIE_HMAC_MD5=y
FILES:= $(LINUX_DIR)/net/sctp/sctp.ko
AUTOLOAD:= $(call AutoLoad,32,sctp)
DEPENDS:=+kmod-lib-crc32c +kmod-crypto-md5 +kmod-crypto-hmac