aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJonas Gorski <jogo@openwrt.org>2011-08-14 23:36:42 +0000
committerJonas Gorski <jogo@openwrt.org>2011-08-14 23:36:42 +0000
commit44b272fd58b2460d16142f15307db198141edcba (patch)
tree3e8ecd85ab6acd61d7530efae663ff204dc94379 /package/kernel
parentf1e7045d309e2d88c18de5e41af9e40e801bd7ec (diff)
downloadupstream-44b272fd58b2460d16142f15307db198141edcba.tar.gz
upstream-44b272fd58b2460d16142f15307db198141edcba.tar.bz2
upstream-44b272fd58b2460d16142f15307db198141edcba.zip
package/kernel: Fix AddDepends/SetDepends calls with make 3.82
The module definitions depend on 001-depends.mk being the first included, but make 3.82 does not sort the results of wildcards anymore, so do an explicit sort of the includes. Found by Philip Prindeville, thanks! SVN-Revision: 27982
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/package/kernel/Makefile b/package/kernel/Makefile
index d3823547aa..13a305d7a1 100644
--- a/package/kernel/Makefile
+++ b/package/kernel/Makefile
@@ -45,5 +45,5 @@ endef
$(eval $(if $(DUMP),,$(call BuildPackage,kernel)))
-include ./modules/*.mk
+include $(sort $(wildcard ./modules/*.mk))
-include $(TOPDIR)/target/linux/*/modules.mk