aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>2018-05-04 10:27:46 -0700
committerJohn Crispin <john@phrozen.org>2018-05-07 10:31:35 +0200
commit441c26da6ad92b0d4529e1844736c55a31bfd45c (patch)
treec1058c8c6295bc0928915dc7fa2e8a4f838f64e8 /package/kernel
parentff6e62b288cab103f9dd4200b49ec6dc47375eb8 (diff)
downloadupstream-441c26da6ad92b0d4529e1844736c55a31bfd45c.tar.gz
upstream-441c26da6ad92b0d4529e1844736c55a31bfd45c.tar.bz2
upstream-441c26da6ad92b0d4529e1844736c55a31bfd45c.zip
kernel: fix build error for external kernel.
fixed build error when external kernel is selected from menuconfig. The patches present in target/linux/generic does not gets applied to external kernel and build fails while compiling mac82011 & regmap-core kernel modules. as a fix added check in Makefile for CONFIG_EXTERNAL_KERNEL_TREE present or not. Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/other.mk6
-rw-r--r--package/kernel/mac80211/Makefile15
2 files changed, 15 insertions, 6 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 4aee820c91..11f28f4319 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -707,11 +707,15 @@ define KernelPackage/regmap
CONFIG_REGMAP_I2C \
CONFIG_SPI=y
FILES:= \
- $(LINUX_DIR)/drivers/base/regmap/regmap-core.ko \
$(LINUX_DIR)/drivers/base/regmap/regmap-i2c.ko \
$(LINUX_DIR)/drivers/base/regmap/regmap-mmio.ko \
$(if $(CONFIG_SPI),$(LINUX_DIR)/drivers/base/regmap/regmap-spi.ko)
AUTOLOAD:=$(call AutoLoad,21,regmap-core regmap-i2c regmap-mmio regmap-spi)
+ ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
+ ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
+ FILES += $(LINUX_DIR)/drivers/base/regmap/regmap-core.ko
+ endif
+ endif
endef
define KernelPackage/regmap/description
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index f3e4d79c80..dc198eb542 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -1797,11 +1797,16 @@ ifneq ($(CONFIG_PACKAGE_kmod-cfg80211)$(CONFIG_PACKAGE_kmod-lib80211),)
endef
endif
-define Build/Configure
- cmp $(PKG_BUILD_DIR)/include/linux/ath9k_platform.h $(LINUX_DIR)/include/linux/ath9k_platform.h
- cmp $(PKG_BUILD_DIR)/include/linux/ath5k_platform.h $(LINUX_DIR)/include/linux/ath5k_platform.h
- cmp $(PKG_BUILD_DIR)/include/linux/rt2x00_platform.h $(LINUX_DIR)/include/linux/rt2x00_platform.h
-endef
+#do not Build/Configure for EXTERNAL KERNEL
+ifeq ($(strip $(CONFIG_EXTERNAL_KERNEL_TREE)),"")
+ ifeq ($(strip $(CONFIG_KERNEL_GIT_CLONE_URI)),"")
+ define Build/Configure
+ cmp $(PKG_BUILD_DIR)/include/linux/ath9k_platform.h $(LINUX_DIR)/include/linux/ath9k_platform.h
+ cmp $(PKG_BUILD_DIR)/include/linux/ath5k_platform.h $(LINUX_DIR)/include/linux/ath5k_platform.h
+ cmp $(PKG_BUILD_DIR)/include/linux/rt2x00_platform.h $(LINUX_DIR)/include/linux/rt2x00_platform.h
+ endef
+ endif
+endif
define Build/Compile
$(SH_FUNC) var2file "$(call shvar,mac80211_config)" $(PKG_BUILD_DIR)/.config