aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2018-11-10 17:36:44 +0200
committerStijn Tintel <stijn@linux-ipv6.be>2018-11-12 19:11:54 +0200
commit43e1b38e4accd7e55755df66aac5800c077334f1 (patch)
treef3c31a3368087a6e65d4c725523ce2fbb921acfe /package/kernel
parenta95bef05799850f468be2676417f1a944ef4e5e0 (diff)
downloadupstream-43e1b38e4accd7e55755df66aac5800c077334f1.tar.gz
upstream-43e1b38e4accd7e55755df66aac5800c077334f1.tar.bz2
upstream-43e1b38e4accd7e55755df66aac5800c077334f1.zip
kernel: drop old bluetooth config symbols
They do not exist in any of the supported kernel versions. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/other.mk14
1 files changed, 1 insertions, 13 deletions
diff --git a/package/kernel/linux/modules/other.mk b/package/kernel/linux/modules/other.mk
index 00ebe4ef6a..3269459397 100644
--- a/package/kernel/linux/modules/other.mk
+++ b/package/kernel/linux/modules/other.mk
@@ -32,32 +32,20 @@ define KernelPackage/bluetooth
TITLE:=Bluetooth support
DEPENDS:=@USB_SUPPORT +kmod-usb-core +kmod-crypto-hash +kmod-crypto-ecb +kmod-lib-crc16 +kmod-hid +!LINUX_3_18:kmod-crypto-cmac +!LINUX_3_18:kmod-regmap +LINUX_4_14:kmod-crypto-ecdh
KCONFIG:= \
- CONFIG_BLUEZ \
- CONFIG_BLUEZ_L2CAP \
- CONFIG_BLUEZ_SCO \
- CONFIG_BLUEZ_RFCOMM \
- CONFIG_BLUEZ_BNEP \
- CONFIG_BLUEZ_HCIUART \
- CONFIG_BLUEZ_HCIUSB \
- CONFIG_BLUEZ_HIDP \
CONFIG_BT \
CONFIG_BT_BREDR=y \
CONFIG_BT_DEBUGFS=n \
- CONFIG_BT_L2CAP=y \
CONFIG_BT_LE=y \
- CONFIG_BT_SCO=y \
CONFIG_BT_RFCOMM \
CONFIG_BT_BNEP \
CONFIG_BT_HCIBTUSB \
CONFIG_BT_HCIBTUSB_BCM=n \
- CONFIG_BT_HCIUSB \
CONFIG_BT_HCIUART \
CONFIG_BT_HCIUART_BCM=n \
CONFIG_BT_HCIUART_INTEL=n \
CONFIG_BT_HCIUART_H4 \
CONFIG_BT_HCIUART_NOKIA=n \
- CONFIG_BT_HIDP \
- CONFIG_HID_SUPPORT=y
+ CONFIG_BT_HIDP
$(call AddDepends/rfkill)
FILES:= \
$(LINUX_DIR)/net/bluetooth/bluetooth.ko \