aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorPhilip Prindeville <philipp@redfish-solutions.com>2017-01-08 21:08:47 -0700
committerJohn Crispin <john@phrozen.org>2017-04-07 17:41:21 +0200
commit43d06ec2c75199591f33943eb2f70e8aae80fd45 (patch)
treec29b498b5c9fe66e1cd04422a7e83acadb193c6a /package/kernel
parent8b8ce566d9c0cccd3c74137a1ef4f060be4a7e75 (diff)
downloadupstream-43d06ec2c75199591f33943eb2f70e8aae80fd45.tar.gz
upstream-43d06ec2c75199591f33943eb2f70e8aae80fd45.tar.bz2
upstream-43d06ec2c75199591f33943eb2f70e8aae80fd45.zip
kernel: add thermal monitor for nct6775/6776
Support for the nct6775/6776 hwmon chips, and other compatibles in the family as well as the Intel on-chip thermal sensors. Signed-off-by: Philip Prindeville <philipp@redfish-solutions.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/hwmon.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/hwmon.mk b/package/kernel/linux/modules/hwmon.mk
index b39a2e2fe8..79c81846c6 100644
--- a/package/kernel/linux/modules/hwmon.mk
+++ b/package/kernel/linux/modules/hwmon.mk
@@ -93,6 +93,21 @@ endef
$(eval $(call KernelPackage,hwmon-ina209))
+define KernelPackage/hwmon-nct6775
+ TITLE:=NCT6106D/6775F/6776F/6779D/6791D/6792D/6793D and compatibles monitoring support
+ KCONFIG:=CONFIG_SENSORS_NCT6775
+ FILES:=$(LINUX_DIR)/drivers/hwmon/nct6775.ko
+ AUTOLOAD:=$(call AutoProbe,nct6775)
+ $(call AddDepends/hwmon,@PCI_SUPPORT @TARGET_x86 +kmod-hwmon-vid)
+endef
+
+define KernelPackage/hwmon-nct6775/description
+ Kernel module for NCT6106D/6775F/6776F/6779D/6791D/6792D/6793D thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-nct6775))
+
+
define KernelPackage/hwmon-ina2xx
TITLE:=INA2XX monitoring support
KCONFIG:=CONFIG_SENSORS_INA2XX