aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-03-18 19:02:28 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-03-18 19:02:28 +0000
commit3b87ad238c80087e6238638caf7cb6e799bf6591 (patch)
tree406fe0c1b2706313e760b9eb90516d34d34ebf18 /package/kernel
parent884f964e62a273f48d0d1596384cb5f719e82d71 (diff)
downloadupstream-3b87ad238c80087e6238638caf7cb6e799bf6591.tar.gz
upstream-3b87ad238c80087e6238638caf7cb6e799bf6591.tar.bz2
upstream-3b87ad238c80087e6238638caf7cb6e799bf6591.zip
kernel: add kmod-usb-net-ipheth (#10157)
SVN-Revision: 30981
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/usb.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/modules/usb.mk b/package/kernel/modules/usb.mk
index e4f099510c..fedff20850 100644
--- a/package/kernel/modules/usb.mk
+++ b/package/kernel/modules/usb.mk
@@ -913,6 +913,21 @@ endef
$(eval $(call KernelPackage,usb-net-sierrawireless))
+define KernelPackage/usb-net-ipheth
+ TITLE:=Apple iPhone USB Ethernet driver
+ KCONFIG:=CONFIG_USB_IPHETH
+ FILES:=$(LINUX_DIR)/drivers/net/usb/ipheth.ko
+ AUTOLOAD:=$(call AutoLoad,64,ipheth)
+ $(call AddDepends/usb-net)
+endef
+
+define KernelPackage/usb-net-ipheth/description
+ Kernel support for Apple iPhone USB Ethernet driver
+endef
+
+$(eval $(call KernelPackage,usb-net-ipheth))
+
+
define KernelPackage/usb-hid
TITLE:=Support for USB Human Input Devices
KCONFIG:=CONFIG_HID_SUPPORT=y CONFIG_USB_HID CONFIG_USB_HIDDEV=y