aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorStijn Tintel <stijn@linux-ipv6.be>2018-06-22 14:42:20 +0300
committerMathias Kresin <dev@kresin.me>2018-06-25 22:00:05 +0200
commit34e22653ac18b6ac7fd368ca47625f665808067f (patch)
treee9ed4fac3645bdaf7aea836a79e18cb7bd1c9ce4 /package/kernel
parent60deb3cdef4ac50a7d0fe9964a0f4a55aca1567e (diff)
downloadupstream-34e22653ac18b6ac7fd368ca47625f665808067f.tar.gz
upstream-34e22653ac18b6ac7fd368ca47625f665808067f.tar.bz2
upstream-34e22653ac18b6ac7fd368ca47625f665808067f.zip
mac80211: enable ath10k LED support by default
Commit 61d57a2f88b90ba951012e66c7c6fae9234c97b4 adds ath10k LED support, but doesn't add an option to actually enable it. After enabling this option, a LED named ath10k-phy0 appears in sysfs, and a trigger can be assigned to it. Since 60deb3cdef4a the default set trigger is the tpt one. Enable it by default, as most devices using ath10k chips shouldn't be severely space-constrained. There are likely many devices that can benefit from having it enabled, like my testing device. Before: text data bss dec hex filename 245311 8899 16 254226 3e112 ath10k_core.ko After: text data bss dec hex filename 245979 8899 16 254894 3e3ae ath10k_core.ko Tested on a D-Link DAP-2695-A1 (ar71xx). Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/mac80211/Makefile7
1 files changed, 7 insertions, 0 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 127251d749..3c88e451f1 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -74,6 +74,7 @@ PKG_CONFIG_DEPENDS:= \
CONFIG_PACKAGE_RTLWIFI_DEBUG \
CONFIG_ATH9K_SUPPORT_PCOEM \
CONFIG_ATH9K_TX99 \
+ CONFIG_ATH10K_LEDS \
CONFIG_ATH10K_THERMAL \
CONFIG_ATH_USER_REGD \
@@ -342,6 +343,11 @@ endef
define KernelPackage/ath10k/config
+ config ATH10K_LEDS
+ bool "Enable LED support"
+ default y
+ depends on PACKAGE_kmod-ath10k
+
config ATH10K_THERMAL
bool "Enable thermal sensors and throttling support"
depends on PACKAGE_kmod-ath10k
@@ -1635,6 +1641,7 @@ config-$(CONFIG_ATH_USER_REGD) += ATH_USER_REGD
config-$(CONFIG_ATH9K_SUPPORT_PCOEM) += ATH9K_PCOEM
config-$(CONFIG_ATH9K_TX99) += ATH9K_TX99
config-$(CONFIG_ATH9K_UBNTHSR) += ATH9K_UBNTHSR
+config-$(CONFIG_ATH10K_LEDS) += ATH10K_LEDS
config-$(CONFIG_ATH10K_THERMAL) += ATH10K_THERMAL
config-$(call config_package,ath9k-htc) += ATH9K_HTC