aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorMichael Yartys <michael.yartys@protonmail.com>2021-06-03 23:50:12 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2021-06-06 00:26:13 +0200
commit2e10ed925e1e07c28570731a429efa5e7de3b826 (patch)
treec5f6676257ef39ca0e1efb566a8179ebc25e536b /package/kernel
parent752cd29904c9304125005b34354b75b968bfc449 (diff)
downloadupstream-2e10ed925e1e07c28570731a429efa5e7de3b826.tar.gz
upstream-2e10ed925e1e07c28570731a429efa5e7de3b826.tar.bz2
upstream-2e10ed925e1e07c28570731a429efa5e7de3b826.zip
ath10k-ct: update to latest version
Changelog: - ath10k-ct: Add security fixes. - ath10k-ct: Add 5.12 kernel version. - ath10k-ct: Fix the beacon/mcast/bcast override issue - ath10k-ct 5.7: Fix setting mcast/bcast/beacon rate from debugfs. - ath10k-ct: Add 5.11 driver. Delete upstreamed patch and refresh the rest. Also, use the opportunity to set PKG_RELEASE to $(AUTORELEASE). Runtime-tested on ipq806x (Netgear R7800). Signed-off-by: Michael Yartys <michael.yartys@protonmail.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/ath10k-ct/Makefile8
-rw-r--r--package/kernel/ath10k-ct/patches/164-ath10k-commit-rates-from-mac80211.patch37
-rw-r--r--package/kernel/ath10k-ct/patches/201-ath10k-add-LED-and-GPIO-controlling-support-for-various-chipsets.patch4
-rw-r--r--package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch4
4 files changed, 8 insertions, 45 deletions
diff --git a/package/kernel/ath10k-ct/Makefile b/package/kernel/ath10k-ct/Makefile
index a225bd8b19..f06d7cf132 100644
--- a/package/kernel/ath10k-ct/Makefile
+++ b/package/kernel/ath10k-ct/Makefile
@@ -1,16 +1,16 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=ath10k-ct
-PKG_RELEASE=2
+PKG_RELEASE=$(AUTORELEASE)
PKG_LICENSE:=GPLv2
PKG_LICENSE_FILES:=
PKG_SOURCE_URL:=https://github.com/greearb/ath10k-ct.git
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2021-01-11
-PKG_SOURCE_VERSION:=9fe1df7d4f783b6b0cd1c99d11979e5a6e6fc40b
-PKG_MIRROR_HASH:=4e30e256716611045e930b95eadaa8bfcadd5bdd8bbe3869cfe0f377920e812b
+PKG_SOURCE_DATE:=2021-06-03
+PKG_SOURCE_VERSION:=b44cd7b2e7b0df5995ece18f358d4dfc40834ba1
+PKG_MIRROR_HASH:=59f961ad425eb1a48fa9c391a325cc0f23845daec9d12673445d3077f9756cf0
# Build the 5.10 ath10k-ct driver version.
# Probably this should match as closely as
diff --git a/package/kernel/ath10k-ct/patches/164-ath10k-commit-rates-from-mac80211.patch b/package/kernel/ath10k-ct/patches/164-ath10k-commit-rates-from-mac80211.patch
deleted file mode 100644
index 842f3ea2a5..0000000000
--- a/package/kernel/ath10k-ct/patches/164-ath10k-commit-rates-from-mac80211.patch
+++ /dev/null
@@ -1,37 +0,0 @@
-From: Sven Eckelmann <sven@narfation.org>
-Date: Tue, 26 Feb 2019 08:06:35 +0100
-Subject: ath10k-ct: apply mac80211 rates to ath10k-ct rate state
-
-The rates from mac80211 have to be copied to the state of ath10k-ct or
-otherwise the ath10k_check_apply_special_rates function overwrites
-them again with some default values. This breaks for example the
-mcast_rate set for a wifi-iface.
-
-Signed-off-by: Sven Eckelmann <sven@narfation.org>
-
---- a/ath10k-5.10/mac.c
-+++ b/ath10k-5.10/mac.c
-@@ -6774,6 +6774,7 @@ static void ath10k_recalculate_mgmt_rate
- return;
- }
-
-+ arvif->mgt_rate[def->chan->band] = hw_rate_code;
- vdev_param = ar->wmi.vdev_param->mgmt_rate;
- ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id, vdev_param,
- hw_rate_code);
-@@ -7000,6 +7001,7 @@ static void ath10k_bss_info_changed(stru
- "mac vdev %d mcast_rate %x\n",
- arvif->vdev_id, rate);
-
-+ arvif->mcast_rate[band] = rate;
- vdev_param = ar->wmi.vdev_param->mcast_data_rate;
- ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id,
- vdev_param, rate);
-@@ -7008,6 +7010,7 @@ static void ath10k_bss_info_changed(stru
- "failed to set mcast rate on vdev %i: %d\n",
- arvif->vdev_id, ret);
-
-+ arvif->bcast_rate[band] = rate;
- vdev_param = ar->wmi.vdev_param->bcast_data_rate;
- ret = ath10k_wmi_vdev_set_param(ar, arvif->vdev_id,
- vdev_param, rate);
diff --git a/package/kernel/ath10k-ct/patches/201-ath10k-add-LED-and-GPIO-controlling-support-for-various-chipsets.patch b/package/kernel/ath10k-ct/patches/201-ath10k-add-LED-and-GPIO-controlling-support-for-various-chipsets.patch
index 749e796148..691b504c0f 100644
--- a/package/kernel/ath10k-ct/patches/201-ath10k-add-LED-and-GPIO-controlling-support-for-various-chipsets.patch
+++ b/package/kernel/ath10k-ct/patches/201-ath10k-add-LED-and-GPIO-controlling-support-for-various-chipsets.patch
@@ -210,7 +210,7 @@ v13:
#include "htt.h"
#include "htc.h"
-@@ -1551,6 +1552,13 @@ struct ath10k {
+@@ -1557,6 +1558,13 @@ struct ath10k {
} testmode;
struct {
@@ -445,7 +445,7 @@ v13:
{
--- a/ath10k-5.10/wmi-tlv.c
+++ b/ath10k-5.10/wmi-tlv.c
-@@ -4585,6 +4585,8 @@ static const struct wmi_ops wmi_tlv_ops
+@@ -4594,6 +4594,8 @@ static const struct wmi_ops wmi_tlv_ops
.gen_echo = ath10k_wmi_tlv_op_gen_echo,
.gen_vdev_spectral_conf = ath10k_wmi_tlv_op_gen_vdev_spectral_conf,
.gen_vdev_spectral_enable = ath10k_wmi_tlv_op_gen_vdev_spectral_enable,
diff --git a/package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch b/package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch
index eae779ef58..6205c9b661 100644
--- a/package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch
+++ b/package/kernel/ath10k-ct/patches/202-ath10k-use-tpt-trigger-by-default.patch
@@ -16,7 +16,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
--- a/ath10k-5.10/core.h
+++ b/ath10k-5.10/core.h
-@@ -1659,6 +1659,10 @@ struct ath10k {
+@@ -1665,6 +1665,10 @@ struct ath10k {
u8 csi_data[4096];
u16 csi_data_len;
@@ -42,7 +42,7 @@ Signed-off-by: Mathias Kresin <dev@kresin.me>
if (ret)
--- a/ath10k-5.10/mac.c
+++ b/ath10k-5.10/mac.c
-@@ -11400,7 +11400,7 @@ int ath10k_mac_register(struct ath10k *a
+@@ -11403,7 +11403,7 @@ int ath10k_mac_register(struct ath10k *a
ar->hw->weight_multiplier = ATH10K_AIRTIME_WEIGHT_MULTIPLIER;
#ifdef CPTCFG_MAC80211_LEDS