aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorTony Ambardar <itugrok@yahoo.com>2021-03-20 23:30:44 -0700
committerPaul Spooren <mail@aparcar.org>2021-03-20 23:57:58 -1000
commit2ba0ab1930bd0f28404835b4393a6c99bcd0196c (patch)
tree1dd8ff1e80f820f980d8bbe5c2d4302f651793e2 /package/kernel
parent956490ad6abead94c8b06e55b687074fa2fd5c62 (diff)
downloadupstream-2ba0ab1930bd0f28404835b4393a6c99bcd0196c.tar.gz
upstream-2ba0ab1930bd0f28404835b4393a6c99bcd0196c.tar.bz2
upstream-2ba0ab1930bd0f28404835b4393a6c99bcd0196c.zip
kernel: robustify dependencies in kmod-sound-hda-core
Dependency tracking for kmod-sound-hda-core is fragile. Enabling some sound codecs (Realtek, Conexant, Sigmatel) implicitly adds a kmod-ledtrig-audio dependency, while an enabled kmod-ledtrig-audio can be picked up through enabling others (e.g. kmod-sound-hda-intel), and the behaviour can change across kernel versions. As kmod-ledtrig-audio is under 2KB, make it an unconditional dependency. Fixes: a374b8f19051 ("kernel: 5.10: update sound modules") Signed-off-by: Tony Ambardar <itugrok@yahoo.com>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/sound.mk5
1 files changed, 1 insertions, 4 deletions
diff --git a/package/kernel/linux/modules/sound.mk b/package/kernel/linux/modules/sound.mk
index 2c11d078e1..e43be25bc6 100644
--- a/package/kernel/linux/modules/sound.mk
+++ b/package/kernel/linux/modules/sound.mk
@@ -304,10 +304,7 @@ $(eval $(call KernelPackage,sound-dummy))
define KernelPackage/sound-hda-core
SUBMENU:=$(SOUND_MENU)
TITLE:=HD Audio Sound Core Support
- DEPENDS:= \
- +LINUX_5_10&&PACKAGE_kmod-sound-hda-codec-realtek:kmod-ledtrig-audio \
- +LINUX_5_10&&PACKAGE_kmod-sound-hda-codec-conexant:kmod-ledtrig-audio \
- +LINUX_5_10&&PACKAGE_kmod-sound-hda-codec-idt:kmod-ledtrig-audio
+ DEPENDS:=+kmod-ledtrig-audio
KCONFIG:= \
CONFIG_SND_HDA_CORE \
CONFIG_SND_HDA_HWDEP=y \