aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorImre Kaloz <kaloz@openwrt.org>2015-03-20 12:13:11 +0000
committerImre Kaloz <kaloz@openwrt.org>2015-03-20 12:13:11 +0000
commit211a4484a1a992280129a2ad9874addf26fa5555 (patch)
tree78ab9370512a35aee3da382330e08ad9c256f0be /package/kernel
parent8f91c80ea13abc5c66cee9f1b6d10d7b392dd16e (diff)
downloadupstream-211a4484a1a992280129a2ad9874addf26fa5555.tar.gz
upstream-211a4484a1a992280129a2ad9874addf26fa5555.tar.bz2
upstream-211a4484a1a992280129a2ad9874addf26fa5555.zip
mac80211: fix 5ghz variable name
Signed-off-by: Imre Kaloz <kaloz@openwrt.org> SVN-Revision: 44907
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/mac80211/Makefile2
-rw-r--r--package/kernel/mac80211/files/lib/wifi/mac80211.sh4
2 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index d71417ec35..c7d7c1e76f 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mac80211
PKG_VERSION:=2015-03-09
-PKG_RELEASE:=2
+PKG_RELEASE:=3
PKG_SOURCE_URL:=http://mirror2.openwrt.org/sources
PKG_BACKPORT_VERSION:=
PKG_MD5SUM:=6d4b04e4ce8a1f54dabfb04f4709453c
diff --git a/package/kernel/mac80211/files/lib/wifi/mac80211.sh b/package/kernel/mac80211/files/lib/wifi/mac80211.sh
index ff0d467ab1..ea229d6c03 100644
--- a/package/kernel/mac80211/files/lib/wifi/mac80211.sh
+++ b/package/kernel/mac80211/files/lib/wifi/mac80211.sh
@@ -86,8 +86,8 @@ detect_mac80211() {
iw phy "$dev" info | grep -q '2412 MHz' || { mode_band="a"; channel="36"; }
vht_cap=$(iw phy "$dev" info | grep -c 'VHT Capabilities')
- 5ghz_cap=$(iw phy "$dev" info | grep -c "Band 2")
- [ "$vht_cap" -gt 0 -a "$5ghz_cap" -gt 0 ] && {
+ cap_5ghz=$(iw phy "$dev" info | grep -c "Band 2")
+ [ "$vht_cap" -gt 0 -a "$cap_5ghz" -gt 0 ] && {
mode_band="a";
channel="36"
htmode="VHT80"