aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2011-10-28 13:11:01 +0000
committerNicolas Thill <nico@openwrt.org>2011-10-28 13:11:01 +0000
commit1f1ae372ddf8045045862371aa37657459a5f981 (patch)
tree6d52e7a77d216492f6b9aaf7d9dd87562ed2f906 /package/kernel
parenta66a8875bbb9bc4c14bdaa41b8545c9ffba7b48b (diff)
downloadupstream-1f1ae372ddf8045045862371aa37657459a5f981.tar.gz
upstream-1f1ae372ddf8045045862371aa37657459a5f981.tar.bz2
upstream-1f1ae372ddf8045045862371aa37657459a5f981.zip
package/kernel: change kmod-libcrc32 dependency to kmod-crypto-crc32c only
SVN-Revision: 28652
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/lib.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/package/kernel/modules/lib.mk b/package/kernel/modules/lib.mk
index 5fb779df73..9154b2eade 100644
--- a/package/kernel/modules/lib.mk
+++ b/package/kernel/modules/lib.mk
@@ -72,9 +72,9 @@ define KernelPackage/libcrc32c
SUBMENU:=$(LIB_MENU)
TITLE:=CRC32 library support
KCONFIG:=CONFIG_LIBCRC32C
- DEPENDS:=+kmod-crypto-core +kmod-crypto-misc
+ DEPENDS:=+kmod-crypto-crc32c
FILES:=$(LINUX_DIR)/lib/libcrc32c.ko
- AUTOLOAD:=$(call AutoLoad,20,crc32c libcrc32c,1)
+ AUTOLOAD:=$(call AutoLoad,20,libcrc32c,1)
endef
define KernelPackage/libcrc32c/description