aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>2016-10-28 15:43:53 +0100
committerJohn Crispin <john@phrozen.org>2016-12-12 16:42:06 +0100
commit1f0ff783f032660ca4f5993a24ff64306f41fd3a (patch)
tree7b9edae4f6a4b07021937cbab245462846de1561 /package/kernel
parentd1a2c3f9b1f79baca2d16b8bf8bd6c409ee56e2e (diff)
downloadupstream-1f0ff783f032660ca4f5993a24ff64306f41fd3a.tar.gz
upstream-1f0ff783f032660ca4f5993a24ff64306f41fd3a.tar.bz2
upstream-1f0ff783f032660ca4f5993a24ff64306f41fd3a.zip
kmod-sched-cake: update & restore DSCP washing
Track upstream changes, incl changes in packet overhead accounting (automatically taking care of linux' packet sizing knowledge), improvements to triple isolated DRR handling (new flow dominance), statistics tweak & allow more packet drops in stressed conditions. Under tests this has significantly improved latency control under 'many flows to one' scenarious as is typical of bittorrent and MS Windows update. I also restored 'DSCP washing' functionality in my repo which follows upstream closely (like a hawk!) with tc keywords 'wash/nowash'. This allows cake to limit/control packets in bands determined by a packet's DSCP but to clear those DSCP bits on qdisc egress. This functionality was originally removed as part of an attempt to push cake into the kernel, which hasn't actually happened as yet. A matching commit is required to iproute2/tc to support the new overhead handling, keyword changes as well as the 'wash/nowash' tweak. Signed-off-by: Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/kmod-sched-cake/Makefile8
1 files changed, 4 insertions, 4 deletions
diff --git a/package/kernel/kmod-sched-cake/Makefile b/package/kernel/kmod-sched-cake/Makefile
index b760c2a358..5fdf6878fd 100644
--- a/package/kernel/kmod-sched-cake/Makefile
+++ b/package/kernel/kmod-sched-cake/Makefile
@@ -9,15 +9,15 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=sched-cake
-PKG_SOURCE_VERSION:=4f62bd17fa34036cb3c8fd4800a709b2734c3de3
-PKG_VERSION:=2016-10-02-$(PKG_SOURCE_VERSION)
+PKG_SOURCE_VERSION:=5da0e8a743ac9690b4f37e638e9f00364763c0f6
+PKG_VERSION:=2016-11-29-$(PKG_SOURCE_VERSION)
PKG_RELEASE:=1
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://github.com/dtaht/sch_cake.git
+PKG_SOURCE_URL:=https://github.com/kdarbyshirebryant/sch_cake.git
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_MIRROR_MD5SUM:=d6fd82607862c16ba5f1007ecfb251eba9e2cc82c55bb3f4aee2fbebf9fa6d2a
+PKG_MIRROR_MD5SUM:=a7e12c301749a65301d6f452e48207839482b35f5458a693327e5896250ee7dd
PKG_MAINTAINER:=Kevin Darbyshire-Bryant <kevin@darbyshire-bryant.me.uk>
include $(INCLUDE_DIR)/package.mk