aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-11-12 22:02:27 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2017-12-16 22:12:40 +0100
commit1ea5f8643767854c21a8817856d7a8ccfdf9f2da (patch)
tree48bd95dfc108d5bb2489fe4b5fe15b8e157ea4a9 /package/kernel
parent00b5df832f8876ebb4f239b8df38e7425ddc2565 (diff)
downloadupstream-1ea5f8643767854c21a8817856d7a8ccfdf9f2da.tar.gz
upstream-1ea5f8643767854c21a8817856d7a8ccfdf9f2da.tar.bz2
upstream-1ea5f8643767854c21a8817856d7a8ccfdf9f2da.zip
kernel: add kmod-crypto-acompress
In kernel 4.14 kmod-crypto-deflate depends on kmod-crypto-acompress. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/crypto.mk14
1 files changed, 13 insertions, 1 deletions
diff --git a/package/kernel/linux/modules/crypto.mk b/package/kernel/linux/modules/crypto.mk
index fc2739811a..3ead640fc9 100644
--- a/package/kernel/linux/modules/crypto.mk
+++ b/package/kernel/linux/modules/crypto.mk
@@ -330,9 +330,21 @@ endef
$(eval $(call KernelPackage,crypto-des))
+define KernelPackage/crypto-acompress
+ TITLE:=Asynchronous Compression operations
+ HIDDEN:=1
+ KCONFIG:=CONFIG_CRYPTO_ACOMP2
+ FILES:=$(LINUX_DIR)/crypto/crypto_acompress.ko
+ AUTOLOAD:=$(call AutoLoad,09,crypto_acompress)
+ $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-acompress))
+
+
define KernelPackage/crypto-deflate
TITLE:=Deflate compression CryptoAPI module
- DEPENDS:=+kmod-lib-zlib-inflate +kmod-lib-zlib-deflate
+ DEPENDS:=+kmod-lib-zlib-inflate +kmod-lib-zlib-deflate +LINUX_4_14:kmod-crypto-acompress
KCONFIG:=CONFIG_CRYPTO_DEFLATE
FILES:=$(LINUX_DIR)/crypto/deflate.ko
AUTOLOAD:=$(call AutoLoad,09,deflate)