aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2020-04-09 09:19:13 +0100
committerKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>2020-04-10 12:26:31 +0100
commit1b973b54ea4d5d20dec5e71c48bff6a3e0bcb4ac (patch)
tree08c6fb5b34ccdcee95355735f42b30ea50b0d7fb /package/kernel
parentc39d01596a8acbdfa5d1ccb98ba0624383a7190a (diff)
downloadupstream-1b973b54ea4d5d20dec5e71c48bff6a3e0bcb4ac.tar.gz
upstream-1b973b54ea4d5d20dec5e71c48bff6a3e0bcb4ac.tar.bz2
upstream-1b973b54ea4d5d20dec5e71c48bff6a3e0bcb4ac.zip
kmod-sched: add act_police
"Whoop whoop, sound of da police" Add an ingress capable traffic policer module configurable with tc. From the man page: The police action allows to limit bandwidth of traffic matched by the filter it is attached to. Basically there are two different algorithms available to measure the packet rate: The first one uses an internal dual token bucket and is configured using the rate, burst, mtu, peakrate, overhead and linklayer parameters. The second one uses an in-kernel sampling mechanism. It can be fine-tuned using the estimator filter parameter. Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/linux/modules/netsupport.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/package/kernel/linux/modules/netsupport.mk b/package/kernel/linux/modules/netsupport.mk
index 6dade49bad..75222889c0 100644
--- a/package/kernel/linux/modules/netsupport.mk
+++ b/package/kernel/linux/modules/netsupport.mk
@@ -867,6 +867,16 @@ define KernelPackage/sched-ctinfo
endef
$(eval $(call KernelPackage,sched-ctinfo))
+define KernelPackage/sched-police
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=Traffic shaper police support
+ DEPENDS:=+kmod-sched-core
+ KCONFIG:=CONFIG_NET_ACT_POLICE
+ FILES:=$(LINUX_DIR)/net/sched/act_police.ko
+ AUTOLOAD:=$(call AutoLoad,71, act_police)
+endef
+$(eval $(call KernelPackage,sched-police))
+
define KernelPackage/sched-ipset
SUBMENU:=$(NETWORK_SUPPORT_MENU)
TITLE:=Traffic shaper ipset support