aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2012-03-18 19:49:22 +0000
committerJo-Philipp Wich <jow@openwrt.org>2012-03-18 19:49:22 +0000
commit15206c5ae060086fb07a8874c1c56a8c2b7b3e2a (patch)
tree9df5920c48d243c351f89c7479aee4e78d554804 /package/kernel
parent63d119db164e4d32fc79b3178e5e201615add5ea (diff)
downloadupstream-15206c5ae060086fb07a8874c1c56a8c2b7b3e2a.tar.gz
upstream-15206c5ae060086fb07a8874c1c56a8c2b7b3e2a.tar.bz2
upstream-15206c5ae060086fb07a8874c1c56a8c2b7b3e2a.zip
Add support for the 8250 UART module.
It has been added at the end of other.mk as i couldn't find a better place for it. Signed-off-by: Christian Gagneraud <chris@techworks.ie> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@30989 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/modules/other.mk18
1 files changed, 18 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 23d558c955..b57d055d36 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -872,3 +872,21 @@ endef
$(eval $(call KernelPackage,nandsim))
+define KernelPackage/serial-8250
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=8250 UARTs
+ KCONFIG:= CONFIG_SERIAL_8250 \
+ CONFIG_SERIAL_8250_NR_UARTS=16 \
+ CONFIG_SERIAL_8250_RUNTIME_UARTS=16 \
+ CONFIG_SERIAL_8250_EXTENDED=y \
+ CONFIG_SERIAL_8250_MANY_PORTS=y \
+ CONFIG_SERIAL_8250_SHARE_IRQ=y
+ FILES:=$(LINUX_DIR)/drivers/tty/serial/8250.ko
+endef
+
+define KernelPackage/serial-8250/description
+ Kernel module for 8250 UART based serial ports.
+endef
+
+$(eval $(call KernelPackage,serial-8250))
+