aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2017-04-18 09:42:04 +0200
committerFelix Fietkau <nbd@nbd.name>2017-04-18 09:45:18 +0200
commit00b32b8326a4de676f55e4a59ac6e7c2c401f9b5 (patch)
tree7264cf91fa8aedbf774da3fc32907dc4bf61db53 /package/kernel
parent97d1c49cacfea2d9f69d8e20d9f60e837293b1ff (diff)
downloadupstream-00b32b8326a4de676f55e4a59ac6e7c2c401f9b5.tar.gz
upstream-00b32b8326a4de676f55e4a59ac6e7c2c401f9b5.tar.bz2
upstream-00b32b8326a4de676f55e4a59ac6e7c2c401f9b5.zip
mac80211: fix kconfig recursive dependency warning
Make brcmfmac depend on !TARGET_uml. Technically, brcmfmac could be built for uml because only SDIO support won't work on that target. However, selectively avoiding the dependency propagation of !TARGET_uml from kmod-mmc to avoid including a reference to BRCMFMAC_SDIO doesn't work. In practice, brcmfmac is completely useless on uml, so let's just disable it there. Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel')
-rw-r--r--package/kernel/mac80211/Makefile3
1 files changed, 1 insertions, 2 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index c5a2577d6e..39cda12855 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -689,7 +689,7 @@ define KernelPackage/brcmfmac
TITLE:=Broadcom IEEE802.11n USB FullMAC WLAN driver
URL:=https://wireless.wiki.kernel.org/en/users/drivers/brcm80211
DEPENDS+= @USB_SUPPORT +kmod-cfg80211 +@DRIVER_11N_SUPPORT +@DRIVER_11AC_SUPPORT +kmod-brcmutil \
- +BRCMFMAC_SDIO&&!TARGET_uml:kmod-mmc \
+ +BRCMFMAC_SDIO:kmod-mmc @!TARGET_uml \
+BRCMFMAC_USB:kmod-usb-core +BRCMFMAC_USB:brcmfmac-firmware-usb
FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/broadcom/brcm80211/brcmfmac/brcmfmac.ko
AUTOLOAD:=$(call AutoProbe,brcmfmac)
@@ -704,7 +704,6 @@ define KernelPackage/brcmfmac/config
config BRCMFMAC_SDIO
bool "Enable SDIO bus interface support"
- depends on !TARGET_uml
default y if TARGET_brcm2708
default n
help