aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/trelay
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-02-24 16:57:38 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-07-15 18:33:56 +0200
commit9c170cb92f4fbb316592c11567a080eb3f6a1fc3 (patch)
tree256a7ec6179af101c9213a002ef309524c5124bf /package/kernel/trelay
parentb29d620ed2521fe6fda40ddafe6cb0f1d70e4503 (diff)
downloadupstream-9c170cb92f4fbb316592c11567a080eb3f6a1fc3.tar.gz
upstream-9c170cb92f4fbb316592c11567a080eb3f6a1fc3.tar.bz2
upstream-9c170cb92f4fbb316592c11567a080eb3f6a1fc3.zip
package: drop PKG_VERSION for purely local packages
In the package guidelines, PKG_VERSION is supposed to be used as "The upstream version number that we're downloading", while PKG_RELEASE is referred to as "The version of this package Makefile". Thus, the variables in a strict interpretation provide a clear distinction between "their" (upstream) version in PKG_VERSION and "our" (local OpenWrt trunk) version in PKG_RELEASE. For local (OpenWrt-only) packages, this implies that those will only need PKG_RELEASE defined, while PKG_VERSION does not apply following a strict interpretation. While the majority of "our" packages actually follow that scheme, there are also some that mix both variables or have one of them defined but keep them at "1". This is misleading and confusing, which can be observed by the fact that there typically either one of the variables is never bumped or the choice of the variable to increase depends on the person doing the change. Consequently, this patch aims at clarifying the situation by consistently using only PKG_RELEASE for "our" packages. To achieve that, PKG_VERSION is removed there, bumping PKG_RELEASE where necessary to ensure the resulting package version string is bigger than before. During adjustment, one has to make sure that the new resulting composite package version will not be considered "older" than the previous one. A useful tool for evaluating that is 'opkg compare-versions'. In principle, there are the following cases: 1. Sole PKG_VERSION replaced by sole PKG_RELEASE: In this case, the resulting version string does not change, it's just the value of the variable put in the file. Consequently, we do not bump the number in these cases so nobody is tempted to install the same package again. 2. PKG_VERSION and PKG_RELEASE replaced by sole PKG_RELEASE: In this case, the resulting version string has been "version-release", e.g. 1-3 or 1.0-3. For this case, the new PKG_RELEASE will just need to be higher than the previous PKG_VERSION. For the cases where PKG_VERSION has always sticked to "1", and PKG_RELEASE has been incremented, we take the most recent value of PKG_RELEASE. Apart from that, a few packages appear to have developed their own complex versioning scheme, e.g. using x.y.z number for PKG_VERSION _and_ a PKG_RELEASE (qos-scripts) or using dates for PKG_VERSION (adb-enablemodem, wwan). I didn't touch these few in this patch. Cc: Hans Dedecker <dedeckeh@gmail.com> Cc: Felix Fietkau <nbd@nbd.name> Cc: Andre Valentin <avalentin@marcant.net> Cc: Matthias Schiffer <mschiffer@universe-factory.net> Cc: Jo-Philipp Wich <jo@mein.io> Cc: Steven Barth <steven@midlink.org> Cc: Daniel Golle <dgolle@allnet.de> Cc: John Crispin <john@phrozen.org> Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'package/kernel/trelay')
-rw-r--r--package/kernel/trelay/Makefile1
1 files changed, 0 insertions, 1 deletions
diff --git a/package/kernel/trelay/Makefile b/package/kernel/trelay/Makefile
index a6bada1a9b..ad83523cd4 100644
--- a/package/kernel/trelay/Makefile
+++ b/package/kernel/trelay/Makefile
@@ -9,7 +9,6 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=trelay
-PKG_VERSION:=0.1
PKG_RELEASE:=2
include $(INCLUDE_DIR)/package.mk