aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mt76
diff options
context:
space:
mode:
authorPawel Dembicki <paweldembicki@gmail.com>2020-03-25 07:08:37 +0100
committerDaniel Golle <daniel@makrotopia.org>2020-04-08 14:05:29 +0100
commit5a5a9b7a7500379e79410a8a955381ec0fa486ae (patch)
tree820d3be016f6ffeb996c594962ebf3c469da1848 /package/kernel/mt76
parent5410a8e2959a9560cdb89231aafa23c71070721d (diff)
downloadupstream-5a5a9b7a7500379e79410a8a955381ec0fa486ae.tar.gz
upstream-5a5a9b7a7500379e79410a8a955381ec0fa486ae.tar.bz2
upstream-5a5a9b7a7500379e79410a8a955381ec0fa486ae.zip
packages: mt76: add 14c3:7610 pci id to list
This commit add patch with 14c3:7610 pci id addition. It was sent upstream. Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com> [bumped PKG_RELEASE] Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/kernel/mt76')
-rw-r--r--package/kernel/mt76/Makefile2
-rw-r--r--package/kernel/mt76/patches/0001-mt76-mt76x0-pci-add-mt7610-PCI-ID.patch30
2 files changed, 31 insertions, 1 deletions
diff --git a/package/kernel/mt76/Makefile b/package/kernel/mt76/Makefile
index 4ee79fe042..965eafb6f8 100644
--- a/package/kernel/mt76/Makefile
+++ b/package/kernel/mt76/Makefile
@@ -1,7 +1,7 @@
include $(TOPDIR)/rules.mk
PKG_NAME:=mt76
-PKG_RELEASE=1
+PKG_RELEASE=2
PKG_LICENSE:=GPLv2
PKG_LICENSE_FILES:=
diff --git a/package/kernel/mt76/patches/0001-mt76-mt76x0-pci-add-mt7610-PCI-ID.patch b/package/kernel/mt76/patches/0001-mt76-mt76x0-pci-add-mt7610-PCI-ID.patch
new file mode 100644
index 0000000000..a2aa0ec36d
--- /dev/null
+++ b/package/kernel/mt76/patches/0001-mt76-mt76x0-pci-add-mt7610-PCI-ID.patch
@@ -0,0 +1,30 @@
+From 9b082c3fd3fc954937444220995cb05662ab2e82 Mon Sep 17 00:00:00 2001
+From: Pawel Dembicki <paweldembicki@gmail.com>
+Date: Wed, 25 Mar 2020 06:51:29 +0100
+Subject: [PATCH] mt76: mt76x0: pci: add mt7610 PCI ID
+
+Add mt7610 PCI id found on D-Link DWR-960 to pci_device_id table.
+
+Run-tested on D-Link DWR-960 with no-name half-size mPCIE card
+with mt7610e.
+
+Signed-off-by: Pawel Dembicki <paweldembicki@gmail.com>
+---
+ mt76x0/pci.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/mt76x0/pci.c b/mt76x0/pci.c
+index e2974e0ae1fc..3bd753cda190 100644
+--- a/mt76x0/pci.c
++++ b/mt76x0/pci.c
+@@ -215,6 +215,7 @@ mt76x0e_remove(struct pci_dev *pdev)
+ }
+
+ static const struct pci_device_id mt76x0e_device_table[] = {
++ { PCI_DEVICE(0x14c3, 0x7610) },
+ { PCI_DEVICE(0x14c3, 0x7630) },
+ { PCI_DEVICE(0x14c3, 0x7650) },
+ { },
+--
+2.20.1
+