aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mt76/Makefile
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@nbd.name>2023-08-26 15:39:12 +0200
committerFelix Fietkau <nbd@nbd.name>2023-08-26 15:59:52 +0200
commit76b1e564d202c09d0035315eb6e958a9b0dd4491 (patch)
treea8e54acd6d119bc370e1a910f16bae12b3c71ab1 /package/kernel/mt76/Makefile
parent866badc361f8feb7acc79f7645af00ad3b385c8d (diff)
downloadupstream-76b1e564d202c09d0035315eb6e958a9b0dd4491.tar.gz
upstream-76b1e564d202c09d0035315eb6e958a9b0dd4491.tar.bz2
upstream-76b1e564d202c09d0035315eb6e958a9b0dd4491.zip
mt76: update to the latest version from the 22.03 branch
94eb0bc1374d wifi: mt76: testmode: use random payload for tx packets f8ece810002b wifi: mt76: add rx_check callback for usb devices 67fbdb7bed90 wifi: mt76: mt7921e: fix race issue between reset and suspend/resume a9b09dd2715f wifi: mt76: mt7921s: fix race issue between reset and suspend/resume ee3eb0d6d52e wifi: mt76: mt7921u: fix race issue between reset and suspend/resume 9706ccef5447 wifi: mt76: mt7921u: remove unnecessary MT76_STATE_SUSPEND 74a29eb4f714 wifi: mt76: mt7921: move mt7921_rx_check and mt7921_queue_rx_skb in mac.c f49e06c4cfce wifi: mt76: sdio: fix the deadlock caused by sdio->stat_work 322656141fa4 wifi: mt76: sdio: poll sta stat when device transmits data dee0a3cbfb03 wifi: mt76: mt7915: fix an uninitialized variable bug 9dd7be2c5164 wifi: mt76: mt7921: fix use after free in mt7921_acpi_read() 0ad02c9a4512 wifi: mt76: sdio: add rx_check callback for sdio devices fe85e5ccbaca wifi: mt76: sdio: fix transmitting packet hangs 206c7ebd7464 wifi: mt76: mt7615: add mt7615_mutex_acquire/release in mt7615_sta_set_decap_offload bf79f5d73e4f wifi: mt76: mt7915: fix possible unaligned access in mt7915_mac_add_twt_setup c4132ab0bea2 wifi: mt76: connac: fix possible unaligned access in mt76_connac_mcu_add_nested_tlv 52eec74986cf wifi: mt76: mt7663s: add rx_check callback 019ef069e754 wifi: mt76: mt76_usb.mt76u_mcu.burst is always false remove related code 0a392ca03db8 wifi: mt76: mt7921: add mt7921_mutex_acquire at mt7921_[start, stop]_ap fbb3554b6236 wifi: mt76: mt7921: add mt7921_mutex_acquire at mt7921_sta_set_decap_offload b55a4eb2ee21 wifi: mt76: mt7921: fix the firmware version report 2d72c9a74011 wifi: mt76: move move mt76_sta_stats to mt76_wcid 873365b06c5c wifi: mt76: add PPDU based TxS support for WED device 0c64a80a61c2 wifi: mt76: connac: fix in comment d11f971a452e wifi: mt76: mt7921: get rid of the false positive reset 2ac22300c7ac wifi: mt76: mt7915: fix mcs value in ht mode 5e45533e4ba2 wifi: mt76: fix uninitialized pointer in mt7921_mac_fill_rx e06376af21dd wifi: mt76: mt7915: do not check state before configuring implicit beamform 0c0bda4aea05 wifi: mt76: mt7921: reset msta->airtime_ac while clearing up hw value cddc4b43ea93 wifi: mt76: mt7921e: fix rmmod crash in driver reload test ebbd68842ee0 wifi: mt76: mt7921: introduce Country Location Control support 763a1d90133b wifi: mt76: mt7921e: fix random fw download fail e4fa68a9b3b3 linux-firmware: update firmware for MT7921 WiFi device 60fcf08fe659 linux-firmware: update firmware for MT7921 WiFi device 9d601f4eee8f linux-firmware: update firmware for MT7922 WiFi device e49b6063fb4b wifi: mt76: move mt76_rate_power from core to mt76x02 driver code 3f27f6adb1ab wifi: mt76: mt76x02: simplify struct mt76x02_rate_power c07f3d2d5ede wifi: mt76: mt7921: fix antenna signal are way off in monitor mode 9059a5de3bd0 wifi: mt76: Remove unused inline function mt76_wcid_mask_test() d75f15ddeb90 wifi: mt76: mt7915: fix bounds checking for tx-free-done command 06df7e689294 wifi: mt76: mt7915: reserve 8 bits for the index of rf registers ad3d0f8db00b wifi: mt76: mt7915: rework eeprom tx paths and streams init 66065073177b wifi: mt76: mt7915: deal with special variant of mt7916 b0114a0abb57 wifi: mt76: mt7915: rework testmode tx antenna setting 6dee964e1f36 wifi: mt76: connac: introduce mt76_connac_spe_idx() 48c116d92939 wifi: mt76: mt7915: add spatial extension index support db6db4ded0fd wifi: mt76: mt7915: set correct antenna for radar detection on MT7915D 2b8f56a72d76 wifi: mt76: mt7915: fix mt7915_mac_set_timing() d554a02554db wifi: mt76: mt7915: move wed init routines in mmio.c 676b10bb203f mt76: mt76x02: fix vht rate power array overrun 7df5b4514721 Revert "mt76: use IEEE80211_OFFLOAD_ENCAP_ENABLED instead of MT_DRV_AMSDU_OFFLOAD" 1b80532eb55f wifi: mt76: mt7921: set MT_DRV_AMSDU_OFFLOAD for USB/SDIO 843955920e19 wifi: mt76: fix receiving LLC packets on mt7615/mt7915 148b7fa2329d wifi: mt76: fix rx checksum offload on mt7615/mt7915/mt7921 9dda9f709c7b wifi: mt76: mt7603: fix beacon interval after disabling a single vif 2cbd5df8cfd8 wifi: mt76: mt7603: fix tx filter/flush function 780ea78ba0ca wifi: mt76: mt7603: rework/fix rx pse hang check 283c46fd1d4f wifi: mt76: mt7603: improve watchdog reset reliablity aa309b5c2a0a wifi: mt76: mt7603: improve stuck beacon handling eb57b7e35f9b wifi: mt76: mt7603: add missing register initialization for MT7628 11f2efecb141 wifi: mt76: mt7603: disable A-MSDU tx support on MT7628 b144bd200519 ieee80211: add EHT 1K aggregation definitions f27ff9a8fb63 mt76: adjust for ieee80211_is_bufferable_mmpdu API change de38fe7d4cb3 wifi: mt76: ignore key disable commands Signed-off-by: Felix Fietkau <nbd@nbd.name>
Diffstat (limited to 'package/kernel/mt76/Makefile')
-rw-r--r--package/kernel/mt76/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/package/kernel/mt76/Makefile b/package/kernel/mt76/Makefile
index 63d3a48085..9b10fc3e6f 100644
--- a/package/kernel/mt76/Makefile
+++ b/package/kernel/mt76/Makefile
@@ -8,9 +8,9 @@ PKG_LICENSE_FILES:=
PKG_SOURCE_URL:=https://github.com/openwrt/mt76
PKG_SOURCE_PROTO:=git
-PKG_SOURCE_DATE:=2022-09-06
-PKG_SOURCE_VERSION:=d70546462b7b51ebc2bcdd5c534fdf3465be62a4
-PKG_MIRROR_HASH:=3d6b68d70a78c0072ed10ab2548344b6b3a70ad99e4edc258fafa16886f4abf9
+PKG_SOURCE_DATE:=2023-08-26
+PKG_SOURCE_VERSION:=de38fe7d4cb365312aa570cf37a4c0eff6e15650
+PKG_MIRROR_HASH:=d8b86332060668b36698e3b3703b8735003c09d7dc612327afa9272eead5238d
PKG_MAINTAINER:=Felix Fietkau <nbd@nbd.name>
PKG_USE_NINJA:=0