aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2013-04-03 10:00:40 +0000
committerJohn Crispin <john@openwrt.org>2013-04-03 10:00:40 +0000
commit7852c48ffd448cec26aeaa0622d00644c3e2158f (patch)
tree1071572a3a5ade9cac99bd8f0c64db75c3cdd871 /package/kernel/modules
parent62b5098b35f0dac0e95487ba6a6283aae4f276c0 (diff)
downloadupstream-7852c48ffd448cec26aeaa0622d00644c3e2158f.tar.gz
upstream-7852c48ffd448cec26aeaa0622d00644c3e2158f.tar.bz2
upstream-7852c48ffd448cec26aeaa0622d00644c3e2158f.zip
add lm92 kernel module
Signed-off-by: John Crispin <blogic@openwrt.org> SVN-Revision: 36181
Diffstat (limited to 'package/kernel/modules')
-rw-r--r--package/kernel/modules/hwmon.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/package/kernel/modules/hwmon.mk b/package/kernel/modules/hwmon.mk
index d549336b3d..bc1f65281d 100644
--- a/package/kernel/modules/hwmon.mk
+++ b/package/kernel/modules/hwmon.mk
@@ -134,6 +134,20 @@ endef
$(eval $(call KernelPackage,hwmon-lm90))
+define KernelPackage/hwmon-lm92
+ TITLE:=LM92 monitoring support
+ KCONFIG:=CONFIG_SENSORS_LM92
+ FILES:=$(LINUX_DIR)/drivers/hwmon/lm92.ko
+ AUTOLOAD:=$(call AutoLoad,60,lm92)
+ $(call AddDepends/hwmon,+kmod-i2c-core)
+endef
+
+define KernelPackage/hwmon-lm92/description
+ Kernel module for LM92 thermal monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-lm92))
+
define KernelPackage/hwmon-lm95241
TITLE:=LM95241 monitoring support
KCONFIG:=CONFIG_SENSORS_LM95241