aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/video.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2010-03-20 10:27:18 +0000
committerFlorian Fainelli <florian@openwrt.org>2010-03-20 10:27:18 +0000
commitd10da4bc310e4f74327bb35fc5e6a86f185dd93d (patch)
tree16fc08343f077b89bbafb238dca9292a0efc3f83 /package/kernel/modules/video.mk
parentd19437f843bbc9f869b300196cd18277613194d1 (diff)
downloadupstream-d10da4bc310e4f74327bb35fc5e6a86f185dd93d.tar.gz
upstream-d10da4bc310e4f74327bb35fc5e6a86f185dd93d.tar.bz2
upstream-d10da4bc310e4f74327bb35fc5e6a86f185dd93d.zip
[package] add sn9c201 webcam driver, patch from Chris Li
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20310 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/video.mk')
-rw-r--r--package/kernel/modules/video.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/package/kernel/modules/video.mk b/package/kernel/modules/video.mk
index 4308a2a19b..c0ab5d15a9 100644
--- a/package/kernel/modules/video.mk
+++ b/package/kernel/modules/video.mk
@@ -323,6 +323,21 @@ endef
$(eval $(call KernelPackage,video-gspca-pac7311))
+define KernelPackage/video-gspca-sn9c20x
+$(call KernelPackage/video-gspca/Depends,@LINUX_2_6 @USB_SUPPORT +kmod-usb-core)
+ TITLE:=sn9c20x webcam support
+ KCONFIG:=CONFIG_USB_GSPCA_SN9C20X
+ FILES:=$(LINUX_DIR)/drivers/media/video/gspca/gspca_sn9c20x.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,75,sn9c20x)
+endef
+
+define KernelPackage/video-gspca-sn9c20x/description
+ The SN9C20X USB Camera Driver (sn9c20x) kernel module.
+endef
+
+$(eval $(call KernelPackage,video-gspca-sn9c20x))
+
+
define KernelPackage/video-gspca-sonixb
$(call KernelPackage/video-gspca/Depends,)
TITLE:=sonixb webcam support