aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/other.mk
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-05-27 18:51:50 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-05-27 18:51:50 +0000
commita2710a9eff4e127bdcd920426a9a575c96e3bcf9 (patch)
treef941b45dc057a0f7f85b996c0868959cabb1c51a /package/kernel/modules/other.mk
parente0c7c1c4409f906225955eaaaa86cad0a2f02f84 (diff)
downloadupstream-a2710a9eff4e127bdcd920426a9a575c96e3bcf9.tar.gz
upstream-a2710a9eff4e127bdcd920426a9a575c96e3bcf9.tar.bz2
upstream-a2710a9eff4e127bdcd920426a9a575c96e3bcf9.zip
Add yealink usb phone kernel packages
SVN-Revision: 7359
Diffstat (limited to 'package/kernel/modules/other.mk')
-rw-r--r--package/kernel/modules/other.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index d7bdf0f428..c8ee64228a 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -358,3 +358,24 @@ define KernelPackage/hwmon-pc87360
AUTOLOAD:=$(call AutoLoad,50,pc87360)
endef
$(eval $(call KernelPackage,hwmon-pc87360))
+
+define KernelPackage/input-core
+ TITLE:=Input device core
+ DESCRIPTION:=Kernel modules for support of input device
+ SUBMENU:=$(EMENU)
+ KCONFIG:=$(CONFIG_INPUT)
+ FILES:=$(LINUX_DIR)/drivers/input/input-core.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,50,input-core)
+endef
+$(eval $(call KernelPackage,input-core))
+
+define KernelPackage/input-evdev
+ TITLE:=Input even device
+ DESCRIPTION:=Kernel modules for support of input device events
+ SUBMENU:=$(EMENU)
+ KCONFIG:=$(CONFIG_INPUT_EVDEV)
+ FILES:=$(LINUX_DIR)/drivers/input/evdev.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,60,evdev)
+endef
+$(eval $(call KernelPackage,input-evdev))
+