aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/other.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2007-09-23 17:14:24 +0000
committerNicolas Thill <nico@openwrt.org>2007-09-23 17:14:24 +0000
commit3d44871496169ab9e78d9674d9ff66e6cb76c1a1 (patch)
treeebcb32c0e9ffd41b5f16e705516d1c717854dfa5 /package/kernel/modules/other.mk
parent5f0272d618f486e694c14c51a3ad42e4232ae9eb (diff)
downloadupstream-3d44871496169ab9e78d9674d9ff66e6cb76c1a1.tar.gz
upstream-3d44871496169ab9e78d9674d9ff66e6cb76c1a1.tar.bz2
upstream-3d44871496169ab9e78d9674d9ff66e6cb76c1a1.zip
move hardware monitoring support in a separate hwmon.mk (before adding other modules)
SVN-Revision: 8983
Diffstat (limited to 'package/kernel/modules/other.mk')
-rw-r--r--package/kernel/modules/other.mk37
1 files changed, 0 insertions, 37 deletions
diff --git a/package/kernel/modules/other.mk b/package/kernel/modules/other.mk
index 0e3368b0b6..7bb75ef9cb 100644
--- a/package/kernel/modules/other.mk
+++ b/package/kernel/modules/other.mk
@@ -332,43 +332,6 @@ endef
$(eval $(call KernelPackage,scx200-wdt))
-define KernelPackage/hwmon
- SUBMENU:=$(OTHER_MENU)
- TITLE:=Hardware monitoring support
- DEPENDS:=@LINUX_2_6
- KCONFIG:= \
- CONFIG_HWMON \
- CONFIG_HWMON_VID \
- CONFIG_HWMON_DEBUG_CHIP=n
- FILES:= \
- $(LINUX_DIR)/drivers/hwmon/hwmon.$(LINUX_KMOD_SUFFIX) \
- $(LINUX_DIR)/drivers/hwmon/hwmon-vid.$(LINUX_KMOD_SUFFIX)
- AUTOLOAD:=$(call AutoLoad,40,hwmon hwmon-vid)
-endef
-
-define KernelPackage/hwmon/description
- Kernel modules for hardware monitoring
-endef
-
-$(eval $(call KernelPackage,hwmon))
-
-
-define KernelPackage/hwmon-pc87360
- SUBMENU:=$(OTHER_MENU)
- TITLE:=PC87360 monitoring support
- DEPENDS:=kmod-hwmon
- KCONFIG:=CONFIG_SENSORS_PC87360
- FILES:=$(LINUX_DIR)/drivers/hwmon/pc87360.$(LINUX_KMOD_SUFFIX)
- AUTOLOAD:=$(call AutoLoad,50,pc87360)
-endef
-
-define KernelPackage/hwmon-pc87360/description
- Kernel modules for PC87360 chips
-endef
-
-$(eval $(call KernelPackage,hwmon-pc87360))
-
-
define KernelPackage/input-core
SUBMENU:=$(OTHER_MENU)
TITLE:=Input device core