aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/netsupport.mk
diff options
context:
space:
mode:
authorJo-Philipp Wich <jow@openwrt.org>2010-08-06 00:58:49 +0000
committerJo-Philipp Wich <jow@openwrt.org>2010-08-06 00:58:49 +0000
commitbdeee67680457879166b2cc4a348f9353e07f38c (patch)
tree7e141e6a4b0527e84061ca5c61d9e98ae320e00d /package/kernel/modules/netsupport.mk
parent39aab4ef92ba3192bc0d1262201ad49e0496f288 (diff)
downloadupstream-bdeee67680457879166b2cc4a348f9353e07f38c.tar.gz
upstream-bdeee67680457879166b2cc4a348f9353e07f38c.tar.bz2
upstream-bdeee67680457879166b2cc4a348f9353e07f38c.zip
[package] kernel: package L2TP v3 ("Pseudowire") modules, restrict them to 2.6.35
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@22501 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'package/kernel/modules/netsupport.mk')
-rw-r--r--package/kernel/modules/netsupport.mk50
1 files changed, 50 insertions, 0 deletions
diff --git a/package/kernel/modules/netsupport.mk b/package/kernel/modules/netsupport.mk
index 4f024f2be0..effd6930fd 100644
--- a/package/kernel/modules/netsupport.mk
+++ b/package/kernel/modules/netsupport.mk
@@ -624,3 +624,53 @@ endef
$(eval $(call KernelPackage,pktgen))
+define KernelPackage/l2tp
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ DEPENDS:=@LINUX_2_6_35
+ TITLE:=L2TPv3 Support
+ KCONFIG:=CONFIG_L2TP
+ FILES:=$(LINUX_DIR)/net/l2tp/l2tp_core.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,32,l2tp_core)
+endef
+
+define KernelPackage/l2tp/description
+ Kernel modules for L2TP V3 Support
+endef
+
+$(eval $(call KernelPackage,l2tp))
+
+define KernelPackage/l2tp-eth
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=L2TP ethernet pseudowire support for L2TPv3
+ DEPENDS:=+kmod-l2tp
+ KCONFIG:= CONFIG_L2TP_V3=y \
+ CONFIG_L2TP_ETH
+ FILES:= \
+ $(LINUX_DIR)/net/l2tp/l2tp_netlink.$(LINUX_KMOD_SUFFIX) \
+ $(LINUX_DIR)/net/l2tp/l2tp_eth.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,32,l2tp_core l2tp_netlink l2tp_eth)
+endef
+
+define KernelPackage/l2tp-eth/description
+ Kernel modules for L2TP V3 pseudowire support
+endef
+
+$(eval $(call KernelPackage,l2tp-eth))
+
+define KernelPackage/l2tp-ip
+ SUBMENU:=$(NETWORK_SUPPORT_MENU)
+ TITLE:=Support for L2TP-over-IP socket family
+ DEPENDS:=+kmod-l2tp
+ KCONFIG:= CONFIG_L2TP_V3=y \
+ CONFIG_L2TP_IP
+ FILES:=$(LINUX_DIR)/net/l2tp/l2tp_ip.$(LINUX_KMOD_SUFFIX)
+ AUTOLOAD:=$(call AutoLoad,32,l2tp_core l2tp_ip)
+endef
+
+define KernelPackage/l2tp-ip/description
+ Kernel modules for L2TP-over-IP socket family
+endef
+
+$(eval $(call KernelPackage,l2tp-ip))
+
+