aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/modules/crypto.mk
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2010-04-29 10:25:57 +0000
committerNicolas Thill <nico@openwrt.org>2010-04-29 10:25:57 +0000
commit36ee230fcaa1f1280045f54ce679db9790f0828d (patch)
tree0137beb73cadea3e1bfe5c817bb28a0ea2c05b28 /package/kernel/modules/crypto.mk
parent840ef1f15803c06dbc101940ad46bb7329c1235a (diff)
downloadupstream-36ee230fcaa1f1280045f54ce679db9790f0828d.tar.gz
upstream-36ee230fcaa1f1280045f54ce679db9790f0828d.tar.bz2
upstream-36ee230fcaa1f1280045f54ce679db9790f0828d.zip
package/kernel: mark a bunch of kmod packages that don't exist on 2.4 as 2.6 only
SVN-Revision: 21251
Diffstat (limited to 'package/kernel/modules/crypto.mk')
-rw-r--r--package/kernel/modules/crypto.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/package/kernel/modules/crypto.mk b/package/kernel/modules/crypto.mk
index 859e8a563e..7c6835135d 100644
--- a/package/kernel/modules/crypto.mk
+++ b/package/kernel/modules/crypto.mk
@@ -64,6 +64,7 @@ endef
define KernelPackage/crypto-hw-padlock
TITLE:=VIA PadLock ACE with AES/SHA hw crypto module
+ DEPENDS:=@LINUX_2_6
KCONFIG:= \
CONFIG_CRYPTO_HW=y \
CONFIG_CRYPTO_DEV_PADLOCK \
@@ -81,6 +82,7 @@ $(eval $(call KernelPackage,crypto-hw-padlock))
define KernelPackage/crypto-hw-geode
TITLE:=AMD Geode hardware crypto module
+ DEPENDS:=@LINUX_2_6
KCONFIG:= \
CONFIG_CRYPTO_HW=y \
CONFIG_CRYPTO_DEV_GEODE
@@ -94,7 +96,7 @@ $(eval $(call KernelPackage,crypto-hw-geode))
define KernelPackage/crypto-hw-hifn-795x
TITLE:=HIFN 795x crypto accelerator
- DEPENDS:=@!TARGET_ubicom32
+ DEPENDS:=@LINUX_2_6 @!TARGET_ubicom32
KCONFIG:= \
CONFIG_CRYPTO_HW=y \
CONFIG_HW_RANDOM=y \
@@ -291,7 +293,7 @@ $(eval $(call KernelPackage,crypto-misc))
define KernelPackage/crypto-ocf
TITLE:=OCF modules
- DEPENDS:=+@OPENSSL_ENGINE @!TARGET_uml
+ DEPENDS:=@LINUX_2_6 +@OPENSSL_ENGINE @!TARGET_uml
KCONFIG:= \
CONFIG_OCF_OCF \
CONFIG_OCF_CRYPTODEV \