aboutsummaryrefslogtreecommitdiffstats
path: root/package/kernel/mac80211
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2020-12-07 13:46:43 +0000
committerDaniel Golle <daniel@makrotopia.org>2021-01-10 19:18:29 +0000
commitcbd67dbdcd6f45ed54a4ec382c5a8ea4d082fa84 (patch)
tree8933e936823be1981d37539be528b36a3ffb3c5e /package/kernel/mac80211
parent2d305ff13a5e24fd2bd54e7dcde89539950974a1 (diff)
downloadupstream-cbd67dbdcd6f45ed54a4ec382c5a8ea4d082fa84.tar.gz
upstream-cbd67dbdcd6f45ed54a4ec382c5a8ea4d082fa84.tar.bz2
upstream-cbd67dbdcd6f45ed54a4ec382c5a8ea4d082fa84.zip
mac80211: use hostapd PID returned from config_add
Use PID returned from config_add instead of querying procd when adding configuration to hostapd. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'package/kernel/mac80211')
-rw-r--r--package/kernel/mac80211/Makefile2
-rw-r--r--package/kernel/mac80211/files/lib/netifd/wireless/mac80211.sh3
2 files changed, 2 insertions, 3 deletions
diff --git a/package/kernel/mac80211/Makefile b/package/kernel/mac80211/Makefile
index 35a7651d1d..e03c91e9c4 100644
--- a/package/kernel/mac80211/Makefile
+++ b/package/kernel/mac80211/Makefile
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
PKG_NAME:=mac80211
PKG_VERSION:=5.8.18-1
-PKG_RELEASE:=3
+PKG_RELEASE:=4
PKG_SOURCE_URL:=@KERNEL/linux/kernel/projects/backports/stable/v5.8.18/
PKG_HASH:=f04a8172423c6a945fc7d9844b04f33fda9ae574e552f8f18ee3bdfcfb494563
diff --git a/package/kernel/mac80211/files/lib/netifd/wireless/mac80211.sh b/package/kernel/mac80211/files/lib/netifd/wireless/mac80211.sh
index 95b6c817ff..7eea198cd9 100644
--- a/package/kernel/mac80211/files/lib/netifd/wireless/mac80211.sh
+++ b/package/kernel/mac80211/files/lib/netifd/wireless/mac80211.sh
@@ -1019,8 +1019,7 @@ drv_mac80211_setup() {
if [ "$no_reload" != "0" ]; then
add_ap=1
ubus wait_for hostapd
- ubus call hostapd config_add "{\"iface\":\"$primary_ap\", \"config\":\"${hostapd_conf_file}\"}"
- local hostapd_pid=$(ubus call service list '{"name": "wpad"}' | jsonfilter -l 1 -e "@['wpad'].instances['hostapd'].pid")
+ local hostapd_pid=$(ubus call hostapd config_add "{\"iface\":\"$primary_ap\", \"config\":\"${hostapd_conf_file}\"}" | jsonfilter -l 1 -e @.pid)
wireless_add_process "$hostapd_pid" "/usr/sbin/hostapd" 1 1
fi
ret="$?"